Domanda L'immagine di sfondo non viene visualizzata nella schermata di accesso. 14.04


Così ho cambiato il mio background sul mio computer con un'immagine che mi è piaciuta su internet. Tuttavia, a differenza del mio portatile, l'immagine di sfondo non viene visualizzata per l'accesso al mio account utente. C'è un modo per risolvere questo problema il 14.04?


1
2017-10-09 19:40


origine


hai abilitato la crittografia della cartella home? se è così che la tua immagine di sfondo non è disponibile fino a dopo aver effettuato l'accesso. - Minos
@Minos No, non l'ho fatto. Non pensavo fosse necessario perché sul mio portatile, il computer l'ha fatto automaticamente. È qualcosa che posso fare dalle impostazioni di sistema o devo fare casino con il terminale? - Msd1391


risposte:


Installa dconf-editor tramite l'Ubuntu Software Center o CLI.

In dconf-editor vai a: com> canonico> unity> unity-greeter

e quindi assicurarsi che la casella di spunta draw-user-backgrounds sia impostata su True.

image of dconf-editor and unity-greeter settings


1
2017-10-10 06:54



L'ho provato e aveva già controllato la scatola. - Msd1391


Un altro motivo potrebbe essere l'autorizzazione errata sul file immagine e / o sulla cartella in cui si trova. Questo è successo a me.

Dovrebbero essere le autorizzazioni per le cartelle 775(rwxrwxr-x) e per i file di immagine 664(Rw-rw-r--).

Ad esempio, se hai:

./wallpapers/animals/cat_0.jpg

wallpapers e animals deve avere i permessi 775 e cat_0.jpg - 664. Puoi impostare i permessi usando chmod:

chmod 775 [folder/file name]

1
2017-07-18 07:35





Segui questi passaggi per configurare l'immagine di sfondo:

  1. Se il tuo sfondo è in un'altra partizione, copialo gentilmente nella tua cartella home - come all'interno della cartella delle immagini.
  2. Fare clic destro su di esso e scegliere Properties quindi selezionare il permissions scheda. Imposta le autorizzazioni come:

proprietario - Leggi e scrivi
  Gruppo: lettura e scrittura
  Altri - Solo lettura

  1. Apri lo sfondo in Image Viewer (EOG), quindi fai clic con il pulsante destro del mouse e scegli Set as Wallpaper

(In questa fase puoi provare e uscire e controllare se l'immagine è apparsa come immagine di sfondo di login). In caso contrario, continua - anche se non ci sarebbe alcun danno nel continuare lo stesso.

  1. Installa Ubuntu Tweak
  2. Apri Ubuntu Tweak e scegli il Tweaks scheda poi il Login Settings sezione - vedi screenshot qui sotto:

enter image description here

  1. Sblocca le impostazioni usando la tua password - guarda la schermata qui sotto:

enter image description here

  1. Scorri verso il basso e premi il Set the same background as the current desktop background pulsante - guarda la schermata qui sotto:

enter image description here

  1. E questo è tutto, lo sfondo è stato impostato come sfondo di accesso.

Ecco la mia configurazione:

Desktop:

enter image description here

Schermata di accesso:
https://askubuntu.com/a/607095/163331

enter image description here


1
2018-04-09 07:46





se tutto il resto fallisce, converti l'immagine in un formato diverso .. nel passato ci sono stati grafici che si sarebbero mostrati come sfondo mentre si è loggati, ma non avrebbero funzionato per la schermata di login fino a quando il formato non è stato cambiato .. dimentica quale sia il formato valido Era sicuro di poterlo capire con una piccola sperimentazione.

oh .. e ci siamo dimenticati di questo .. ma se si utilizza un ambiente desktop separato invece di unità, è necessario cambiare lo sfondo di sfondo in unità, perché unity greeter non si cura di quale sfondo si utilizza in altri ambienti desktop. per me c'è lxde quindi devi sempre ricordare di cambiare il mio sfondo in unità allo stesso come il mio sfondo in lxde.


0
2018-04-09 05:55





Puoi impostarlo var/lib/AccountsService/users/yourusername, sotto [User] sezione. Io uso questo stesso file per impostare uno sfondo di accesso diverso dal desktop.

Ecco come è il mio. Notare il Background= linea

[com.canonical.indicator.sound.AccountsService]
PlayerName=''
Timestamp=0
Title=''
Artist=''
Album=''
ArtUrl=''
PlayerIcon=<('themed', <['application-default-icon', 'application-default', 'application']>)>

[User]
Language=en
FormatsLocale=en_US.UTF-8
XSession=gnome
Background=/usr/share/backgrounds/LOGIN-WARNING.png
Icon=/usr/share/pixmaps/faces/penguin.jpg
SystemAccount=false

[InputSource0]
ibus=pinyin

[InputSource1]
xkb=us

[InputSource2]
xkb=ru

0
2018-04-09 06:25