Domanda Problema di installazione HTK [duplicato]


Questa domanda ha già una risposta qui:

Sto cercando di installare gli strumenti HTK. Ho questo messaggio quando digito make all:

error : "/usr/bin/ld : cannot find -lX11"

1
2018-04-13 17:01


origine


Hai installato il libx11-dev pacchetto? - steeldriver
Potresti aggiungere qualche dettaglio in più? Che cosa Esattamente hai fatto, cosa ti aspettavi di accadere e cosa invece è successo? Hai riscontrato avvisi o messaggi di errore? Si prega di riprodurli nella loro interezza nella tua domanda È possibile selezionare, copiare e incollare il contenuto del terminale e la maggior parte dei messaggi di dialogo in Ubuntu. per favore modificare il tuo post per aggiungere informazioni invece di pubblicare un commento. (vedere Come faccio a fare una buona domanda?) - David Foerster
David Foerster: ./configure non sta controllando per libX11, gli errori accadranno quando viene eseguito 'make': error : "/usr/bin/ld : cannot find -lX11" ... I.e. quando i 32 bit libx11-dev manca. - Knud Larsen
Infine, HTk funziona con architettura a 32 bit, ho risolto il problema migrando a 32bit ubuntu - Chakikou11


risposte:


HTK è costruito con gcc -m32, il che significa che sono necessari i prerequisiti di build i386: libx11-dev:i386 . E: HTK-3.4.1 → Il timestamp è 2009, molto prima che venissero introdotti i nuovi percorsi di Debian. Per favore fallo : ./configure CFLAGS=-I/usr/include/x86_64-linux-gnu

È inoltre possibile installare il pacchetto binario HTK-tools htk-tools_3.4.1-ubuntu14_i386.deb : Vedi Errore durante l'installazione di htk-tool


1
2018-04-13 18:06



Un'altra vecchia scoreggia che sa le cose che i bambini non sanno più (entrambe le risposte upvotes anche se è contro la politica aziendale per duplicare le risposte invece di chiudere come un duplicato ... - Fabby