Domanda Display del monitor esterno su Thinkpad W520 con 12.04


So che c'è molto materiale riguardo a questi problemi, ma in gran parte sembra obsoleto e nulla sembra funzionare per la mia situazione:

  • ThinkPad W520 (chipset Intel 3000 e Nvidia 1000M)
  • Sistema operativo: Ubuntu 12.04.3.
  • Impostazione della scheda grafica del BIOS: Optimus
  • Rilevamento automatico di Optimus del BIOS: disabled

Ho usato la wiki Bumblebee qui sotto per installare e configurare Bumblebee:   https://wiki.ubuntu.com/Bumblebee#Installation

Dopo aver impostato il mio BusID per la scheda grafica su "PCI: 01: 00.0" (vedi i file di configurazione di seguito), sono in grado di eseguire optirun firefox e i test virtuali come optirun glxspheres64 e glxspheres64. Quindi, credo che tutto vada bene con l'installazione di Bumblebee, tranne che non riesco a collegarmi al mio monitor esterno (via VGA). Qualche idea su come fare questo? Il W520 ha la VGA (e DisplayPort) collegata alla scheda Nvidia, come descritto da Zachary Sunberg:

http://zachstechnotes.blogspot.com/2012/04/post-title.html

Quindi, credo che ciò renda le cose un po 'complicate quando si tenta di collegare la VGA a un monitor esterno. Credo di dover utilizzare un clone server / schermo, descritto nei miei tentativi documentati di seguito:

  1. Ho provato il seguente post per configurare i monitor esterni,

    http://hillspcworld.com/forum/index.php?topic=2.0

    Ma il riavvio dopo il punto 7, provoca l'arresto completo del sistema operativo (schermata nera dopo il bootloader che dice "Impossibile scrivere byte: pipe rotta"). Credo che questo sia dovuto al fatto che il server xorg abbia distrutto il mio sistema in qualche modo.

  2. Ho provato un approccio simile nel seguente tutorial, ma ho avuto lo stesso crash di in (1) durante il riavvio dopo aver installato xorg-dev:

    http://sagark.org/optimal-ubuntu-graphics-setup-for-thinkpads/

A partire da ora, mi chiedo dove andare da qui. Ho un paio di lead in basso, qualche idea su quale sia il problema o cosa posso fare? C'è un suggerimento migliore?   http://zachstechnotes.blogspot.com/2012/04/post-title.html

https://github.com/Bumblebee-Project/Bumblebee/issues/77

https://github.com/Bumblebee-Project/Bumblebee/issues/522

Inoltre, ecco alcuni dei miei file (fammi sapere se c'è una configurazione migliore - l'unica modifica che ho apportato è stata decommentare il "BusID PCI: 01: 00.0" nel xorg.conf.nvidia file:

lucas@lucas-ThinkPad-W520:~$ more /etc/bumblebee/xorg.conf.nvidia 
Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false" EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting may be needed in some platforms with more than one
#   nvidia card, which may confuse the proprietary driver (e.g.,
#   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
    BusID "PCI:01:00:0"

#   Setting ProbeAllGpus to false prevents the new proprietary driver
#   instance spawned to try to control the integrated graphics card,
#   which is already being managed outside bumblebee.
#   This option doesn't hurt and it is required on platforms running
#   more than one nvidia graphics card with the proprietary driver.
#   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
#   If this option is not set, the new Xorg may blacken the screen and
#   render it unusable (unless you have some way to run killall Xorg).
    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "none"

Nouveau driver:

lucas@lucas-ThinkPad-W520:~$ more /etc/bumblebee/xorg.conf.nouveau  Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false" EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nouveau"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting is needed on Ubuntu 13.04.
#   BusID "PCI:01:00:0"

Configurazione di Bumblebee:

lucas@lucas-ThinkPad-W520:~$ more /etc/bumblebee/bumblebee.conf 
# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect. [bumblebeed]
# The secondary Xorg server DISPLAY number VirtualDisplay=:8
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all. KeepUnusedXServer=false
# The name of the Bumbleblee server group name (GID name) ServerGroup=bumblebee
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits. TurnCardOffAtExit=false
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored. NoEcoModeOverride=false
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below) Driver=
# Directory with a dummy config file to pass as a -configdir to secondary X XorgConfDir=/etc/bumblebee/xorg.conf.d

## Client options. Will take effect on the next optirun executed. [optirun]
# Acceleration/ rendering bridge, possible values are auto, virtualgl and
# primus. Bridge=auto
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv. VGLTransport=proxy
# List of paths which are searched for the primus libGL.so.1 when using
# the primus bridge PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primu s
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available? AllowFallbackToIGC=false


# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#         bbswitch - new in BB 3, recommended if available
#       switcheroo - vga_switcheroo method, use at your own risk
#             none - disable PM completely
# https://github.com/Bumblebee-Project/Bumblebee/wiki/Comparison-of-PM-methods

## Section with nvidia driver specific options, only parsed if Driver=nvidia [driver-nvidia]
# Module name to load, defaults to Driver if empty or unset KernelDriver=nvidia-current PMMethod=auto
# colon-separated path to the nvidia libraries LibraryPath=/usr/lib/nvidia-current:/usr/lib32/nvidia-current
# comma-separated path of the directory containing nvidia_drv.so and the
# default Xorg modules path XorgModulePath=/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

## Section with nouveau driver specific options, only parsed if Driver=nouveau [driver-nouveau] KernelDriver=nouveau PMMethod=auto XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

Grazie.


10
2017-12-21 10:20


origine


Non sono sicuro che ciò possa essere d'aiuto, ma in generale ho trovato che i driver configurati fuori dalla scatola in una nuova installazione sono generalmente i migliori da usare e il passaggio dei driver causa sempre più problemi di quanti ne risolva. Prova ad avviare il cd live con il tuo secondo monitor collegato. Se non è attivo riconfigurato dopo l'accesso apt-get install arandar quindi apri l'arander e configuralo. Se funziona, copia la configurazione e installa gli stessi driver. - virtualxtc
A proposito, penso che tu intenda arandr non arandar - iX3


risposte:


Prima di tutto, ho smesso di provare con 12.04.3 o 12.04.4 LTS e ho usato 13.10 invece. Credo che le versioni LTS non siano in grado di stare al passo con la situazione grafica in continuo cambiamento e ho imparato a fondo.

Ecco i passaggi generali che ho seguito:

1) Install latest intel drivers, hope that intel-virtual-output, which is the integrated version of screenclone. If it's not packaged, compile that stuff from source.
2) In your xorg.conf.nvidia ensure the option preventing external screens is disabled.
3) Xrandr as usual :)

Questa risorsa è utile:

http://www.unixreich.com/blog/2013/linux-nvidia-optimus-on-thinkpad-w520w530-with-external-monitor-finally-solved/

Ho anche creato un post sul blog su questo problema per Ubuntu 14.04:

http://blog.lukeswart.net/wordpress/

Quest'ultimo dovrebbe anche avere informazioni per aiutare un principiante durante la compilazione dei driver dalla fonte.

PS: Come novizio di Linux, questo processo richiedeva molto tempo e posso solo sperare che questo post aiuti qualcuno. L'installazione di un monitor esterno su un laptop con Optimus con porte di visualizzazione cablate sul chip Nvidia è un processo molto scoraggiante per un nuovo utente Linux.

Come utente che ha bisogno di usare Linux per il mio lavoro, l'intera situazione rispetto alla protezione dei driver proprietari Optimus porta imbarazzo a tutta la comunità tecnologica.


3
2018-02-11 11:35



Sai se esistono dei luoghi alternativi in ​​cui posso trovare le informazioni contenute nel link che hai proposto? il sito web sembra morto ora - maguirre
Funziona nel mio browser (firefox). O solo Google: "Linux NVidia Optimus su ThinkPad W520 / W530 con monitor esterno - finalmente risolto, Come NVidia Optimus funziona su laptop Thinkpad W520 / W530" - modulitos