Domanda Adobe Flash Plugin è vulnerabile / obsoleto in 14.04 ma non ci sono aggiornamenti in Firefox


Sto usando Ubuntu 14.04 LTS. Quando apro un sito che richiede plug-in Flash (ad esempio Youtube), Firefox dice Questo plugin è vulnerabile e dovrebbe essere aggiornato.

Screenshot

Tuttavia se clicco Controlla gli aggiornamenti... non c'è nessun aggiornamento. Questo è ciò il sito di aggiornamento elencati:

  1. Shockwave Flash 11.2 r202 (stato aggiornato 11.2.202.424)
  2. Plug-in Java (TM) 11.25.2 (stato aggiornato 11.25.2)

Quindi cosa dovrei fare?


57
2017-12-16 11:44


origine


Forse qualcosa è cambiato nelle impostazioni di Firefox (about: config). Prova a provare il flash in un altro browser per scoprire chi è il colpevole. - Muzaffar
genere about:plugins nella barra degli indirizzi di Firefox e cerca Flash Player. Che versione elenca? Elenca 11.2.202.424 o 11.2.202.424? Vai a Tester per la versione flash di Adobe (facendo clic su "Attiva Adobe Flash"), e guarda quale versione dice di avere. Dice "Avete installato la versione 11,2 2202,424" o "11,2,202,425"? 11.2.202.425 è l'ultima versione corretta. Per qualche motivo, Firefox sembra rilevare male la versione installata. Finalmente, quale versione del pacchetto flash hai installato sul tuo computer? - D.W.
@ D.W. Se installo adobe-flashplugin: about:plugins dice 11.2.202.359; Il sito di adobe dice 11,2,202,359 Se installo fashplugin-installer: about:plugins dice 11.2.202.425; Il sito di adobe dice 11,2,202,425 - BornToCode
@BornToCode, eccellente - è un ottimo indizio. 11.2.202.425 è l'ultima versione - quella è quella che vuoi. Sembra che la risposta sia da usare flashplugin-installer (non  adobe-flashplugin). Questo, combinato con i dettagli di DJCrashDummy, suona come la risposta. Vuoi pubblicare una risposta che spieghi tutto questo? Questo dovrebbe essere molto utile per gli altri. - D.W.
Ho installato 11.2.202.481 e questo sembra essere vulnerabile? Dovrei sempre consentire? Nessun problema con Chrome. - JohnnyBizzle


risposte:


Ho fatto qualche ricerca a mozilla e adobe e prova con entrambe le versioni recenti di LTS (14.04 e 12.04) e sono abbastanza sicuro che sia solo un problema di numerazione del plugin flash!

Riassumere:
Se apri in Firefox "tools" - "add-ons" - "plugins" guarda rispettivamente a controllo mozilla e hai la versione 11,2 2202,425 (nota le virgole!), riceverai questo messaggio di errore.
e se la tua versione è 11.2.202.425 (stessa versione, solo con punti alla numerazione) tutto va bene.

Quindi non farti prendere dal panico, il tuo sistema è sicuro! ;-)


Ma posso capire che questo messaggio è fastidioso e quindi questo sarebbe il modo più semplice per sbarazzarsene:
aprire un terminale e inserire sudo apt-get update && sudo apt-get install -y flashplugin-installer, digita la tua password di root (nessun carattere verrà visualizzato) e aspetta solo che venga eseguito!


Consiglierei questa soluzione solo nel caso in cui abbiate già installato la versione più recente, ma ricevo comunque il messaggio di errore le differenze tra i pacchetti flash!


52
2017-12-18 20:46



Per adobe-flashplugin, entrambi i controlli mostrano 11.2.202.359, ma per flashplugin-installer è 11.2.202.425. - BornToCode
dopo aver provato ad aggiornarlo, dice "già la versione più recente", ma il messaggio anoying appare ancora - cipricus
Ho digitato nel terminale la stringa precedente, 'sudo apt-get update && sudo apt-get install -y flashplugin-installer'. Ha funzionato perfettamente sul mio 14.04 LTS. Ho installato 'flashplugin-installer_11.2.202.491ubuntu0.1.04.04.1_amd64.deb'. - bluepearlsky
Non avevo virgole nel numero di versione, ma ho usato questa soluzione lo stesso e ha funzionato perfettamente! - Ingrid
Questo ha funzionato per me - Linga


La seguente soluzione ha funzionato per me:

sudo apt-get purge flashplugin-installer
sudo apt-get install adobe-flashplugin

8
2017-07-21 04:46





La migliore soluzione al problema di un'installazione Flash vulnerabile e obsoleta, o anche di una versione aggiornata che funziona male, potrebbe essere quella di disinstallare completamente Flash. Spesso non è necessario, poiché HTML5 ha ampiamente preso il sopravvento. Pertanto rimuovere Flash è una soluzione reale per molte persone e dovrebbe essere probabilmente preso in considerazione primo prima di passare ad altre soluzioni che tentano di mantenere Flash installato mentre lo si mantiene in uno stato corrente (o semi-corrente).

Come occupyflash.org dice:

Flash Player è morto. È passato il tempo È buggy. Si schianta molto. Richiede aggiornamenti di sicurezza costanti. Non funziona più   dispositivi mobili. È un fossile, rimasto dall'era del chiuso   standard e controllo unilaterale aziendale della tecnologia web. siti web   che si basano su Flash presenti in modo completamente incoerente (e spesso   inutilizzabile) esperienza per percentuale in rapida crescita degli utenti che   non usare un browser desktop. Introduce un po 'di sicurezza spaventosa e   problemi di privacy tramite i cookie Flash.

Flash rende il web meno accessibile. A questo punto, sta trattenendo il web.


7
2018-04-07 16:47



Puoi dare un vero percorso per disinstallare il software? Preferibilmente un comando di shell. - Tarrasch
Comando Shell per disinstallare flash: "sudo apt-get remove adobe-flashplugin" ha funzionato per me e ora posso guardare i video - wranvaud
Purtroppo, uno ha ancora bisogno di guardare i video in streaming di Amazon. Di solito uso Chrome, ma ho bisogno di Firefox anche per questo. Preferirei usare HTML5! - Rafael_Espericueta
Non ho nemmeno pensato di farlo. Grande suggerimento. - DazBaldwin


Come annunciato da Adobe Adobe Flash Player 11.2 sarà l'ultima versione per indirizzare Linux come piattaforma supportata.


4
2017-12-16 21:10



Esiste tuttavia un 11.2.202.425 aggiornamento disponibile al momento della stesura di questo documento - Fabby
L'aggiornamento @Fabby non è uguale a una versione più recente, Firefox continuerà a lamentarsi, a meno che non si passi a pepper flash o html5, che è quello che ho fatto - Sergiy Kolodyazhnyy
@Serg: спасибо: I've mai avuto problemi, circa qualunque siti web che si lamentano, ma poi, io non sono l'utente medio ... ;-) - Fabby


Il problema principale in questa situazione è la versione obsoleta di Flash Player in Firefox, che è 11.2
Allo stesso tempo, gli utenti di Google Chrome godono dell'ultima versione supportata da Google.

Il trucco è di passare da Firefox utilizzando Flash Player a Pepper Flash Player da Google Chrome.

  1. Budud B Bud Bud B B B Bud B Bud B Bud B B Bud B B B B B B B B B B B B B B B B B B B B B

    sudo apt-get remove flashplugin-installer
      sudo apt-get rimuovi adobe-flashplugin

  2. Installa il plugin per i nuovi giocatori di Rinat Ibragimov.
    È un wrapper che consente agli utenti Linux di utilizzare Pepper Flash (che è fornito in bundle con Google Chrome) in Firefox e altri browser compatibili con NPAPI.
    L'ultima versione in questo momento è 0.3.1 e tutto sembra funzionare.

    sudo add-apt-repository ppa: nilarimogard / webupd8
      sudo apt-get update
      sudo apt-get install freshplayerplugin

  3. Installa Pepper Flash Player stesso da Google Chrome Stable:

    sudo apt-get install pepperflashplugin-nonfree
      sudo update-pepperflashplugin-nonfree --install

    Se lo desideri, puoi installare Flash Player da diverse versioni:

    Google Chrome Beta:

    sudo update-pepperflashplugin-nonfree --install --beta --unverified

    Google Chrome Unstable:

    sudo update-pepperflashplugin-nonfree --install --unstable --unverified

Ora è il momento di verificare la versione:

  1. Adobe Informazioni mostra che ho 18,0,0,209
  2. circa: addons Budud B Bud B Bud B B Bud B B Bud B Bud B Bud B Bud B B B B B B B B B B Bud B B B B B B
  3. Mozilla Controlla i tuoi plugin la pagina mostra che ho la versione 13.1.2.3, è obsoleta e offre l'aggiornamento ora, ma l'aggiornamento non funziona (e non ne abbiamo bisogno, in realtà)

3
2017-07-15 05:21





Questo non è un problema di Ubuntu, perché lo stesso messaggio appare in FF su Mageia e openSUSE,

La soluzione è semplice installare un plugin per Pepper Flash per Firefox, Il team di SUSE ha fornito un plug-in la scorsa settimana, non appena si è verificato un problema, in modo che su openSUSES flash è 16.0 come in Chrome

Spero che ci sia un PPA per Ubuntu

http://www.webupd8.org/2014/05/install-fresh-player-plugin-in-ubuntu.html

P.S: l'ultimo flash 11.2 è davvero obsoleto (vulnerabile), la modifica della versione con apt-get non risolve il problema


1
2017-12-25 16:36



È utile includere i comandi qui nel caso in cui il collegamento si interrompa. Inoltre, le 11. release ricevono ancora aggiornamenti per distribuzioni Linux, ma non le nuove funzionalità (che è fastidioso) - Wilf


al momento non riesco a riprodurre il tuo errore, ma questo dovrebbe risolvere il tuo problema:

aprire un terminale e inserire sudo apt-get update && sudo apt-get install adobe-flashplugin, digita la tua password di root (nessun carattere verrà visualizzato), conferma la finestra di dialogo e questo è tutto!
beh ... forse devi riavviare il tuo browser!


0
2017-12-16 12:36



l'ultima versione flash dovrebbe essere 11.2.202.425! - DJCrashdummy
se hai problemi, dai un'occhiata Questo! - DJCrashdummy
ok ... ora ho lo stesso errore! ma penso che sia un assegno sbagliato perché stai ancora usando il flash 11.2 (per conto di adobe non vengono più rilasciate nuove versioni per linux)! - Ho fatto il controllo mozilla e anche guardato adobe ed entrambi mi dicono che sto usando la versione più recente 11.2.202.425! quindi tutto dovrebbe andare bene ...! - DJCrashdummy
Perché adobe-flashplugin invece di flashplugin-installer? - BornToCode
ottimo ha spiegato le differenze dei pacchetti flash! - DJCrashdummy


  1. Accesso https://get.adobe.com/flashplayer/
  2. Scegli "Apt for Ubuntu 10.04+" in "Il tuo sistema:"
  3. Apri con l'applicazione di aggiornamento del software
  4. Installare..

Dimentica i passaggi precedenti ... Si aggiornerà con una vecchia versione del plugin Flash. Quindi non funziona. Nuovi passaggi di lavoro sotto :)

  1. Accesso https://get.adobe.com/flashplayer/
  2. Scegli ".tar.gz per altri linux"
  3. Attendere fino al termine del download
  4. Estrai libflashplayer.so nella cartella "~ / .mozilla / plugins" per il tuo utente. Per tutti gli utenti è necessario estrarre la cartella / opt / firefox (è necessario il permesso di root).

Ha fatto questi ultimi passaggi, non ho più questi messaggi noiosi.


0
2017-12-18 21:22



dopo pochi giorni e un sacco di diversi tentativi di leggere i vari post del forum - questo funziona per me. [Linux xxxx 3.16.0-30-generic # 40-Ubuntu SMP Lun 12 gennaio 22:06:37 UTC 2015 x86_64 x86_64 x86_64 GNU / Linux] - harayz