Domanda Come posso disattivare Bluetooth all'avvio del sistema?


Come posso disattivare Bluetooth all'avvio del sistema?


277
2017-10-16 21:02


origine


Non penso che "dovrebbe essere la configurazione predefinita naturale", le persone sono destinate a voler utilizzare il Bluetooth sui loro computer senza dover accenderlo (non sembra che tu abbia un mouse o una tastiera Bluetooth, se quelli erano tuoi dispositivi di input primari da utilizzare per il Bluetooth all'avvio). Tuttavia, sono d'accordo che sarebbe utile avere un modo per scegliere come si desidera che il Bluetooth sia in boot. - roadmr
La cosa normale e naturale è di lasciarti scegliere, nelle impostazioni bluetooth, se lo vuoi attivare o disattivare quando si avvia. Non è naturale avere persone che lo disattivano o accendono ogni volta che accendono il computer. Stiamo parlando di rendere Linux il miglior sistema desktop, non il peggiore, vero? - Robert
Siamo d'accordo che lasciare che le persone scelgano è l'opzione migliore. Vedi qui per alcuni modi possibili di farlo. answers.launchpad.net/ubuntu/+source/bluez/+question/51440 - roadmr
Questo è bug # 1073669. - colan
È incredibile che, alla quattordicesima edizione, stiamo ancora "insegnando" agli sviluppatori di Ubuntu cose come "l'opzione di avere bluetooth acceso o spento all'avvio dovrebbe essere disponibile per gli utenti normali, e non solo per gli appassionati di ricerca in linee interminabili di forum pubblici ". - Rodrigo


risposte:


Oltre 18.04 utenti che non hanno naturalmente un /etc/rc.local, dovrai crearne uno e renderlo eseguibile. Per semplificare le cose, puoi semplicemente incollare il seguente comando in un terminale:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Correre sudoedit /etc/rc.local e aggiungilo prima della linea exit 0:

rfkill block bluetooth

Dovresti comunque essere in grado di abilitare il Bluetooth tramite l'applet sulla barra superiore.

Questo dovrebbero funziona per la maggior parte dei sistemi, ma sembra che ci siano alcuni bug in agguato nell'ACPI del kernel per Thinkpads. Se sei su un Thinkpad, aggiungi quanto segue a /etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Oppure dai un'occhiata ibm-acpi - Driver IBM ThinkPad ACPI Extras - alcuni rapporti suggeriscono che ibm-acpi include il controllo Bluetooth (tra le altre cose belle). Ma non ho l'hardware, quindi sono completamente incapace di verificare queste affermazioni. In bocca al lupo.


189
2017-08-18 09:00



Per Thinkpad (e solo Thinkpad) questo funziona: echo disable > /proc/acpi/ibm/bluetooth in /etc/rc.local - Marius Gedminas
rfkill block bluetooth ha funzionato per Thinkpad T430u - bmaupin
Nessuno dei due ha funzionato per me (ThinkPad x201) quando li ho posizionati uno alla volta in /etc/rc.local. Il rfkill block bluetooth il comando funziona, ma non all'avvio. Il flag -x è impostato su /etc/rc.local. Sono in esecuzione Xubuntu 13.10. - Kyle Falconer
Su Ubuntu 15.10 con systemd ne hai bisogno di altro per riattivare l'uso del etc/rc.local file: askubuntu.com/a/696226/34298 - rubo77
se il nostro rc.local è solo un file vuoto, dove dovremmo aggiungere 'rfkill block bluetooth'? - Sss


Ho trovato un how-to con una "soluzione" pulita Qui (collegamento all'archivio per i posteri)

In realtà cambiando /etc/bluetooth/main.conf è stato abbastanza per me

Dall'articolo:

Cerca la voce:

InitiallyPowered = true

e cambia il valore in:

InitiallyPowered = false

Era abbastanza per me, anche se l'articolo descrive alcuni altri passaggi che potrebbero essere o non essere necessari.

Sopra Ubuntu 17.10 e Ubuntu 18.04 l'opzione InitiallyPowered è stato sostituito con AutoEnable


70
2018-06-25 18:00



non funziona per samsung laptop 530u3b, il bluetooth è sempre attivo dopo il riavvio e il risveglio - Maxim Kim
Questo funzionerebbe solo se usassi anche la risposta di Saeed Zarinfam /etc/init.d/bluetooth stop in rc.local. Sembra che all'avvio del servizio accenda il bluetooth. Avevo bisogno di entrambi per farlo funzionare. (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
Non ha funzionato per me su thinkpad t420 - UpTheCreek
"Cercare la voce" non è di alcuna utilità per quelli di noi di chi main.conf non contiene questo parametro o alcun commento che indica la sua posizione predefinita. Quindi, sotto il quale [Heading] dovremmo metterlo? - underscore_d
Nel mio caso è stato AutoEnable = false, ma comunque +1 per la soluzione giusta dal posto giusto. - Arman Petrosyan


Per disabilitare il caricamento del driver bluetooth all'avvio:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

Inserisci:

blacklist btusb

Abilitarlo in un secondo momento dovrebbe essere solo:

sudo modprobe btusb

23
2017-08-18 16:59



Grazie per quello, sembra funzionare, ma stavo cercando di evitare la roba della linea di comando come da mia domanda originale. Si potrebbe pensare che sarebbe semplice come spuntare una casella in modo che si ricordi che non voglio che BT si avvii automaticamente ma sembra più complicato di così. Con l'unità di Ubuntu per tempi di avvio più rapidi e l'attenzione generale sul consumo energetico nei laptop e nei netbook, sono sorpreso che questo non sia mai stato affrontato. Apprezzo l'aiuto però.
"Esegui gedit come root e modifica /etc/modprobe.d/blacklist.conf" <- ok, è quella riga di comando in meno per ya? - maco
Funziona bene su Samsung Q35 con Ubuntu 13.10, mentre l'approccio 'rfkill block bluetooth' no. Grazie! - user27164
DELL E6410 funziona per me. Bene che può funzionare di nuovo in movimento senza reset. - Ruslan Gerasimov
Non preoccuparti di cercare di "evitare le cose da linea di comando" quando stai configurando il sistema operativo. Ctrl + Alt + T e un paio di ctrl-shift-V (incollare) troppo per chiedere? - doug65536


Passaggio 1: vai al terminale e digita il seguente comando per modificare il sistema /etc/rc.local file:

gksudo gedit /etc/rc.local

Passaggio 2: aggiungere la seguente riga prima del exit 0 linea:

rfkill block bluetooth

16
2018-05-04 20:44



Questo è impostato come soft block su bluetooth, penso sia come disattivare il suo servizio e funziona bene. - Smile.Hunter
@Roberto: $ man rfkill: "Disabilita il dispositivo corrispondente all'indice indicato."Nonostante il nome, è solo disabilitando BT, basta provare il comando rfkill block bluetoothsul terminale, dovresti vedere l'icona diventare grigia. - Daniel


Da ubuntu 16.04 in poi systemd gestisce servizi di avvio come bluetooth ... per visualizzare il problema dello stato corrente seguito in un terminale

sudo systemctl status bluetooth.service 

per disattivare Bluetooth in caso di avvio questo

sudo systemctl disable bluetooth.service

quindi al prossimo riavvio il bluetooth non sarà attivo ... per abilitare il problema bluetooth

sudo systemctl enable bluetooth.service

12
2017-08-01 15:08



Questo funziona per me, ma come effetto collaterale, blueman-applet si è fermato anche a lavorare. Inizia, ma non appare nell'area dell'indicatore, quindi non esiste un modo rapido per abilitare il bluetooth, solo nel terminale. - Yuri Gor
In Xubuntu, almeno, se fai clic su Blueman, ha l'opzione "Disattiva Bluetooth". Penso che questo sia ciò che l'OP vorrebbe automatizzato. La tua soluzione elimina completamente Blueman, rendendo più difficile riattivare il Bluetooth se lo desideri. - Adrian Keister
Metti sudo systemctl disable bluetooth.service && sudo systemctl stop bluetooth.service in uno script Disable e chmod 755 su di esso. Fai lo stesso per sudo systemctl abilita bluetooth.service && sudo systemctl avvia bluetooth.service in uno script Abilita. - Adrian Keister


Digitare quanto segue in un terminale:

sudo gedit /etc/modprobe.d/blacklist.conf

Nella parte inferiore del file, aggiungi la riga:

blacklist bluetooth

Salvare il file e riavviare - Bluetooth ora dovrebbe essere disabilitato.


7
2017-10-16 21:25



Questo non funzionerà sul mio PC ... - Floqqi
@Floqqi: puoi provare di nuovo? Ho aggiornato la mia risposta. - Nathan Osman
Ho provato circa 20 cose sul mio thinkpad di Ubuntu 12, questo è l'unico che ha fatto il trucco. - OlivierBlanvillain


È possibile modificare i servizi avviati all'avvio con l'aiuto di BUM.

Installalo: sudo apt-get install bum

Correre: sudo bum

enter image description here 

Deseleziona la casella e fai clic Applicare.


7
2018-05-05 00:09



Grazie, desgua, stavo pensando a questo tipo di strumenti. Ne ho usato alcuni in passato ma diventano obsoleti e la nuova ubuntu, con la loro ossessione minimalista, non ha nulla del genere. E 'questo il solo che tu sappia o il migliore lo sai? - Robert
Forse funziona ma all'inizio mi ha deluso perché ha iniziato a mostrare il bluetooth come non attivato all'avvio, perché? e come non in esecuzione quando rfkill, l'applet e hciconfig lo mostrano in esecuzione. Io spengo e riaccendo ma bum continua a mostrare il servizio come spento. Ho attivato il servizio all'avvio ma lo stato del servizio continua a essere errato. - Robert
scusa non funziona su ElementaryOS Freya - Hoang Tran
Durante l'esecuzione ottengo molti avvisi di "utilizzo di valori non inizializzati". Scusa, non posso fidarmi di quello. - doug65536
Ora, il pacchetto non è disponibile. Si dice, Bum è virtuale. - Satya Prakash


Penso che il modo migliore sia disabilitare il servizio dall'inizio. Esiste un metodo generale per disabilitare i servizi che funziona perfettamente:

sudo sh -c "echo 'manual' > /etc/init/bluetooth.override"

Questo funziona con Ubuntu 13.10 e probabilmente anche con versioni precedenti.


5
2018-01-18 09:49



come attivare il bluetooth, mentre si utilizzano le impostazioni fornite in seguito? Diciamo che voglio usarlo solo per 5 minuti. ogni 10 stivali .. - b1r3k