Domanda Funziona solo la versione "vulnerabile" di Flash Player


Per l'ultimo anno, ho utilizzato Shockwave Flash 11.1 r102 obsoleto in Firefox, perché le versioni più recenti (11.2 r202.243 o .280) non funzionano per me. In genere, con le versioni r202, ottengo spazi vuoti invece di immagini Streetview e video di YouTube. Chromium sembra utilizzare qualsiasi flash player che installo in FF e il suo comportamento segue FF.

Recentemente, ho iniziato a ricevere terribili avvertenze rosse sul fatto che r102 fosse "vulnerabile" (che ritengo, ovviamente) ed è disabilitato e devo attivarlo manualmente ogni volta che voglio usarlo sui siti di cui sopra.

Quindi, negli ultimi giorni, ho provato nuovamente le versioni r202, ma continuano a non funzionare. Attualmente sto usando Lubuntu 12.10 con FF20.0, ma ho lo stesso comportamento con le stesse versioni di Flashplayer in Ubuntu 10.04.

Posso aspettarmi che alcune versioni funzionino "normalmente" in Ubuntu?


1
2018-04-19 15:47


origine


Non probabile Hai provato a utilizzare le versioni nel repository invece di installarlo da solo? Sei 32 o 64 bit? - jmite
Sto usando 32 bit. La versione r102 che funziona (ma è vulnerabile) è stata ottenuta con il copia-incolla dal mio sistema di backup 10.04LTS l'anno scorso. Ho ottenuto le versioni r202.243 e r202.280 installando temporaneamente il programma di installazione di Flashplugin tramite Synaptic, quindi copiando il file libflashplayer.so da / usr / lib / flashplugin-installer in una cartella "sicura", quindi disinstallando il programma di installazione di flashplugin, quindi copia-incolla il file .so in / usr / lib / mozilla / plugins. Per ottenere r202.243, ho dovuto forzare la versione. Così ora ho 3 diversi file .so che posso copiare / incollare nei plugin ../mozilla come mi piace. - user44405
Ho provato vari altri metodi, come Flash-Aid 2.2.3 (installato ma attualmente disabilitato), installando flashplugin-installer normalmente, e seguendo i link di Adobe, ma con risultati di spazzatura. Sono felice di provare altri suggerimenti (preferibilmente GUI). Per ripetere la mia domanda, devo aspettarmi di poter vedere i video di YouTube e le immagini di Streetview in 12.10? Mi aspetto di sì, ma nessuno in realtà ha detto così ... Grazie - user44405
Bene - ho Lubuntu 12.04 su un netbook con Firefox 19.0 e che funziona bene per Streetview e per YouTube. In modo che risponda alla mia domanda "dovrebbe funzionare?" L'installazione flash è Flashplugin-installer 11.2.202.270ubuntu12.04.1 & libflashplayer.so è in / usr / lib / flashplayer-installer con collegamenti via / usr / lib / mozilla / plugins e / etc / alternative / mozilla-flashplayer. Ho provato di nuovo a ricreare quella configurazione sul mio fastidioso 12.10 Lubuntu, rimuovendo i file libflashplayer.so esistenti e installando il programma di installazione di flashplugin tramite Synapt, ma questo mi riporta indietro a nessuna immagine di Streetview, ecc. - user44405
Sembra essere un noto Adobe Bug di anni senza alcuna correzione: bugbase.adobe.com/index.cfm?event=bug&id=3161034 - user44405


risposte:


Ho appena scaricato l'ultimo file tar.gz per 64bit linux da adobe.com (versione 11.2.202.280). Mi sembra che firefox prenda il file da / usr / share / ubufox / plugins /, dove libflashplayer.so è un link simbolico a /usr/lib/flashplugin-installer/libflashplayer.so. Quindi ho decompresso il pacchetto e ho copiato libflashplayer.so in / usr / lib / flashplugin-installer /. Dopo aver riavviato Firefox, il plugin Flash funziona, non si lamenta più. Io uso Ubuntu 12.04 e ho installato il programma di installazione di flashplugin64, ma penso che non importi finché si trova la posizione del vecchio plugin. In bocca al lupo!


0
2018-04-24 08:32