Domanda Come posso installare una stampante Canon o un driver dello scanner?


Ho provato ad installare i driver MP190, ma è apparso un messaggio che mi mostra che è necessario avere libcupsys2. Capisco che libcup2 è un aggiornamento di libcupsys2.

Come lo risolvo? Esistono driver proprietari per la mia stampante o scanner Canon?


29
2017-11-03 05:38


origine


Mi dispiace far rivivere questo thread. Sono riuscito a ottenere i 2 driver installati dal ppa per rarare. Ho anche stampato lavorando bene anche via rete. Tuttavia, posso far funzionare la funzione di scansione. scangearmp si installa bene ma viene fuori dicendo che non riesce a trovare uno scanner sia via usb che via rete. C'è qualche file che posso modificare in modo da poter dire a Scangearmp dove cercare lo scanner? Xsane non lo trova neanche. A proposito, se digito "scanimage -L" ottengo una risposta per dire che c'è uno scanner disponibile. - JediBrooker


risposte:


PPA

Ho trovato la soluzione!

sudo add-apt-repository ppa:michael-gruz/canon-trunk  
sudo apt-get update

per le versioni precedenti utilizzare ppa:michael-gruz/canon.

Finalmente,

sudo apt-get install [model]

Stampante

Dove [modello] vorrebbe:

Driver Canon Canon Pixma iP Series

Canon iP100 Ubuntu Driver -  cnijfilter-ip100series
Canon iP1800 Ubuntu Driver - cnijfilter-ip1800series
Canon iP1000 Ubuntu Driver - cnijfilter-pixmaip1000series
Canon iP1500 Ubuntu Driver - cnijfilter-pixmaip1500series
Canon iP1900 Ubuntu Driver - cnijfilter-ip1900series
Canon iP 2200 Ubuntu Driver - cnijfilter-ip2200series
Canon iP2500 Ubuntu Driver - cnijfilter-ip2500series
Canon iP2600 Ubuntu Driver - cnijfilter-ip2600series
Canon iP2700 Ubuntu Driver - cnijfilter-ip2700series
Canon iP3300 Ubuntu Driver - cnijfilter-ip3300series
Canon iP3500 Ubuntu Driver - cnijfilter-ip3500series
Canon iP3600 Ubuntu Driver - cnijfilter-ip3600series
Canon iP4200 Ubuntu Driver - cnijfilter-ip4200series
Canon iP4500 Ubuntu Driver - cnijfilter-ip4500series
Canon iP4700 Ubuntu Driver - cnijfilter-ip4700series
Canon iP4800 Ubuntu Driver - cnijfilter-ip4800series
Canon iP5200 Ubuntu Driver - cnijfilter-ip5200series
Canon iP6600 Ubuntu Driver - cnijfilter-ip6600series
Canon iP7500 Ubuntu Driver - cnijfilter-ip7500series

Driver Canon Pixma MG Series Ubuntu

Canon MG5100 Ubuntu Driver - cnijfilter-mg5100series
Canon MG5200 Ubuntu Driver - cnijfilter-mg5200series
Canon MG6100 Ubuntu Driver - cnijfilter-mg6100series
Canon MG8100 Ubuntu Driver - cnijfilter-mg8100series

Driver Ubuntu Canon PIXMA MP Series

Canon MP140 Ubuntu Driver - cnijfilter-mp140series
Canon MP160 Ubuntu Driver - cnijfilter-mp160series
Canon MP190 Ubuntu Driver - cnijfilter-mp190series
Canon MP210 Ubuntu Driver - cnijfilter-mp210series
Canon MP240 Ubuntu Driver - cnijfilter-mp240series
Canon MP490 Ubuntu Driver - cnijfilter-mp490series
Canon MP500 Ubuntu Driver - cnijfilter-mp500series
Canon MP510 Ubuntu Driver - cnijfilter-mp510series
Canon MP520 Ubuntu Driver - cnijfilter-mp520series
Canon MP540 Ubuntu Driver - cnijfilter-mp540series
Canon MP550 Ubuntu Driver - cnijfilter-mp550series
Canon MP560 Ubuntu Driver - cnijfilter-mp560series
Canon MP600 Ubuntu Driver - cnijfilter-mp600series
Canon MP610 Ubuntu Driver - cnijfilter-mp610series
Canon MP630 Ubuntu Driver - cnijfilter-mp630series
Canon MP640 Ubuntu Driver - cnijfilter-mp640series

Driver Ubuntu Canon serie MX

Canon MX320 Ubuntu Driver - cnijfilter-mx320series
Canon MX330 Ubuntu Driver - cnijfilter-mx330series
Canon MX350 Ubuntu Driver - cnijfilter-mx350series
Canon MX360 Ubuntu Driver - cnijfilter-mx360series
Canon MX410 Ubuntu Driver - cnijfilter-mx410series
Canon MX420 Ubuntu Driver - cnijfilter-mx420series
Canon MX860 Ubuntu Driver - cnijfilter-mx860series
Canon MX870 Ubuntu Driver - cnijfilter-mx870series
Canon MX880 Ubuntu Driver - cnijfilter-mx880series

Driver Ubuntu Canon PIXUS Series

Pixus 550 Ubuntu Driver - cnijfilter-pixus5510iseries
Pixus 560 Ubuntu Driver - cnijfilter-pixus560iseries
Pixus 850 Ubuntu Driver - cnijfilter-pixus850iseries
Pixus 860 Ubuntu Driver - cnijfilter-pixus860iseries
Pixus 865 Ubuntu Driver - cnijfilter-pixus865iseries
Pixus 950 Ubuntu Driver - cnijfilter-pixus950iseries
Pixus 990 Ubuntu Driver - cnijfilter-pixus990iseries
Canon Pixus ip3100 Ubuntu Driver - cnijfilter-pixusip3100series
Canon Pixus ip4100 Ubuntu Driver - cnijfilter-pixusip4100series
Canon Pixus ip8600 Ubuntu Driver - cnijfilter-pixusip8600series

Riferimento: http://www.ubuntubuzz.com/2011/06/download-install-canon-printer-driver.html

Scanner

Se si desidera scaricare il applicazione scanner (e driver) installa uno di questi pacchetti (in base al tuo numero di modello):

scangearmp-mg5100series
scangearmp-mg5200series
scangearmp-mg6100series
scangearmp-mg8100series
scangearmp-mp140series
scangearmp-mp160series
scangearmp-mp190series
scangearmp-mp210series
scangearmp-mp240series
scangearmp-mp250series
scangearmp-mp270series
scangearmp-mp280series
scangearmp-mp490series
scangearmp-mp495series
scangearmp-mp510series
scangearmp-mp520series
scangearmp-mp540series
scangearmp-mp550series
scangearmp-mp560series
scangearmp-mp600series
scangearmp-mp610series
scangearmp-mp630series
scangearmp-mp640series
scangearmp-mx320series
scangearmp-mx330series
scangearmp-mx340series
scangearmp-mx350series
scangearmp-mx360series
scangearmp-mx410series
scangearmp-mx420series
scangearmp-mx860series
scangearmp-mx870series
scangearmp-mx880series

Quindi cerca "Scan Gear MP" o esegui dal terminale:

scangearmp

24
2017-11-05 19:25



molto utile - grazie - n3rd
La mia stampante CanonMP610 funziona perfettamente sotto 12.04 gnome classic, ma solo @ 600 dpi. Voglio stampare le foto. Il metodo sopra ha funzionato per me (anche se dovevo sostituire pangolino con oneiric nell'indirizzo PPA), posso installare la stampante, selezionare la stampante nel menu di stampa (ad esempio Firefox, Openoffice, qualsiasi cosa ...), scegliere tra diversi risoluzioni, fino ad oltre 2000; il software dice che sta stampando, le bolle di notifica mi dicono che il lavoro di stampa è iniziato e terminato, ma, indovina ... la stampante rimane morta ...! Ha iniziato una taglia, qualcuno può aiutare, per favore? - Tinellus
Voglio anche aggiungere: il metodo suggerito da Michael K non funziona per me, c'è ancora una dipendenza non soddisfatta (libpopt0: i386) che non riesco a installare (ubuntu 12.04, gnome classic) - Tinellus
@Tinellus: ho inviato un'email al proprietario del PPA per stabilire se intende creare un repository preciso; se risponde, farò un commento per te qui. - fossfreedom♦
il supporto sembra fermarsi alle 14.10 - Tim Tisdall


Ho risposto a questo Questo QUINTA domanda, ma ecco quella risposta, ristampata.

Per 14.04-16.04 fare quanto segue:

  1. Scarica i driver da Supporto Canon.

  2. Estrai l'archivio di file in una directory. Da quella directory:

    cd ~/Downloads
    tar -xf Linux_UFRII_PrinterDriver_*.tar.*
    sudo dpkg -i Linux_UFRII_PrinterDriver_*/*/Debian/*_$(dpkg --print-architecture).deb
    sudo apt-get install -f
    
  3. Non dovrebbe essere necessario riavviare, ma se il passaggio successivo non riesce, riavviare e riprovare.

  4. Esegui "Aggiungi stampante". Questo dovrebbe apparire automaticamente quando fai clic sul pulsante "Aggiungi". Dagli qualche secondo e il cinguettio della stampante si mostra magicamente.

EDIT 27/02/16 (16.04beta) Aggiornato il collegamento al driver 3.10 (hanno aggiornato il loro sito Web). Tutto ha funzionato semplicemente usando sopra, non ha bisogno di riavviare.

EDIT 9/8/16: la versione attuale del driver è ora 3.20. Rende agnostici i comandi di installazione sia per la versione del driver che per l'architettura del sistema.


7
2018-03-10 15:24



@KarlRichter: Potrebbe per favore rivedere il mio modifiche e anche rivedere il aiuto per la modifica per migliorare la leggibilità delle tue risposte in futuro ... ;-) - Fabby
Non ho dato una risposta, ho appena modificato uno e non vedo dove si trova il conflitto con l'aiuto del montaggio - per favore sii più specifico. Non riesco a rivedere le tue modifiche perché non ho abbastanza reputazione. - Karl Richter
Il link deve essere cambiato. Quella pagina non mostra affatto i driver. È possibile fare clic su un pulsante di supporto che porta a una pagina dei driver. Il sito può rilevare automaticamente Linux e non visualizzare driver. Se ciò accade, scegli la tua versione (32 o 64 bit) per vedere i driver. - revnoah
@revnoah grazie per la nota. ho aggiornato il collegamento alla pagina del driver. proverò con 3.10 e aggiornerò i passaggi se necessario. - JimB
Sono ancora stranito dai formati delle date americane ... - David Foerster


Da molte (ma non tutte) stampanti e scanner Canon possiamo scaricare un driver Linux proprietario da Canon Asia. Se un driver non era ancora elencato nello strumento di ricerca web Canon linkato sopra, potremmo ancora trovare collegamenti ai file downlaod del driver appropriati dal Panoramica dei prodotti Canon pagina. Scarica il Archivi di pacchetti Debian per installare i driver di stampante proprietari con Ubuntu Software Center con un doppio clic su di essi.

L'applicazione scanner proprietaria scangearmp non verrà installato con SANE e quindi non può essere utilizzato con applicazioni basate su SANE. Dopo l'installazione viene eseguito dal terminale:

scangearmp

Si noti che i driver disponibili supportano una serie di stampanti ma non un sottoinsieme di questa serie. Questo è solitamente indicato dalla numerazione del prodotto (ad esempio per un Pixma IP 2820 si scarica il driver per la serie IP2800, per un PIXMA MX457 è necessario il driver per la serie MX450, ecc.)

I driver più vecchi potrebbero anche essere disponibili da ppa: michael-Gruz / canon-tronco.

Alcune stampanti Canon sono supportate anche da Gutenprint piloti. La stampa di foto senza bordi o ad alta risoluzione potrebbe non essere supportata.

È possibile notare che questi driver consentono la stampa, ma in genere non supportano completamente tutte le funzionalità della stampante. Questo è stato così per tutte le stampanti Canon per ragioni che solo Canon conosce.

Nel caso in cui abbiamo bisogno di un driver che supporta pienamente tutte le funzionalità della stampante, è disponibile un driver di stampa disponibile in commercio Turboprint che funziona davvero bene ma potresti non voler supportare il loro piano di licenze piuttosto strano e costoso (a partire da $ 34 per un computer e due stampanti con aggiornamenti gratuiti per soli 6 mesi).


3
2018-02-16 08:19





libcupsys2 è un pacchetto virtuale in 11.10 che installa libcups2. Forse il driver Canon (è un driver proprietario credo) controlla questo pacchetto. Potresti installare questo meta-pacchetto facendo:

sudo apt-get install libcupsys2

Questo non dovrebbe installare nulla di nuovo, ma contrassegnare il pacchetto stesso come installato.

Quindi installare il pacchetto utilizzando il seguente comando:

dpkg -i --ignore-depends=libcupsys2 foo.deb

(Sostituire foo.deb dal pacchetto del driver)


2
2017-11-03 07:28



Mi dispiace, ma ho ancora lo stesso problema. Nonostante installi libcupsys2, i driver mi mostrano un problema di dipendenza. - Brallan Aguilar
Puoi copiare e incollare i messaggi nel tuo posting pls? - Michael K
okay, ho modificato il mio post, spero che funzioni, altrimenti commento ancora qui - Michael K
Siamo spiacenti, sono stato in grado di installarlo, ma quando provo a installare altri pacchetti, prima devo riparare le dipendenze e i driver vengono disinstallati - Brallan Aguilar


potresti doverlo usare

sudo add-apt-repository ppa:michael-gruz/canon-trunk

L'ho fatto. E la stampante funziona bene.


2
2018-02-19 16:23



grazie, ha lavorato per me il 12.04 (ppa:michael-gruz/canon no) - TooTone


Si potrebbe provare da questo http://ubuntuhandbook.org/index.php/2014/12/canon-driver-scangear-mp-ubuntu-14-04/ :

...

Un ppa di terze parti contiene driver e scangear per le stampanti Canon di uso comune, disponibili per Ubuntu 14.04 LTS e derivati, come Linux Mint 17.

Di seguito sono supportati i dispositivi:

  • bjf9000, bjf900, bjs300, bjs500, serie bjs700
  • Serie e500, e510, e600, e610
  • Serie i250, i255, i550, i560, i850, i860, i950, i990
  • iP100, iP1800, iP1900, iP2200, iP2500, IP2600, iP2700, IP3000, iP3300, iP3500, iP3600, iP4000, iP4200, iP4300, iP4500, iP4600, IP4700, ip4800, ip4900, iP5000, iP5200, ip6600, ip7200, ip7500, IP8500, serie ip90
  • serie ix6500
  • mg2100, mg2200, mg3100, mg3200, mg4100, mg4200, mg5100, MG5200, mg5300, mg5400, MG6100, mg6200, mg6300, mg8100, serie mg8200.
  • MP140, MP160, MP190, MP210, MP230, MP240, MP250, MP270, MP280, MP490, MP495, MP500, MP510, MP520, MP540, MP550, MP560, MP600, MP610, MP620, MP630, MP640, MP750, MP780 serie.
  • MX320, MX330, MX340, MX350, MX360, mx370, mx390, MX410, MX420, mx430, mx450, MX510, mx520, mx710, mx720, MX860, MX870, mx880, MX890, mx920 serie.
  • pixmaip1000, serie pixmaip1500.
  • pixus250, pixus255, pixus550, pixus560, pixus850, pixus860, pixus950, pixus990 series
  • pixusip3100, pixusip4100, serie pixusip8600

Installa Canon Drivers / ScanGear in Ubuntu 14.04:

  1. Per iniziare, premere Ctrl+alt+T sulla tastiera per aprire il terminale. Quando si apre, il comando seguente e premi invio per eseguire:

      sudo add-apt-repository ppa:inameiname/stable
    

Inserisci la tua password utente quando chiede e premi Invio per continuare. Questo aggiungerà il repository PPA nel tuo sistema.

  1. Successivamente, apri Synaptic Package Manager da Unity Dash. Se non lo trovi, cerca e installalo da Ubuntu Software Center.

Fare:

  • Fare clic sul pulsante Ricarica per aggiornare la cache di sistema.   
    • Per installare un driver di stampa:       Nella casella Filtro rapido, digitare cnijfilter.
    • Per installare ScanGear:       Nella casella Filtro rapido, digitare scangearmp.
  • Seleziona un pacchetto nell'elenco dei risultati che corrisponde al tuo dispositivo.
  • Fai clic con il tasto destro del mouse sul pacchetto e seleziona "Segna per l'installazione"
  • Infine fai clic sul pulsante "Applica" per installare il driver.

Una volta installati i driver di stampante e scanner, collegare il dispositivo al computer e avviare il test di utility Printers se funziona. E lancia l'utility Simple Scan e seleziona lo scanner dal menu app Documenti -> Preferenze -> Origine scansione per verificare se lo scanner funziona.


0
2018-03-14 16:17