Domanda Sfarfallio fastidioso in 16.04 LTS - Chrome


Ho aggiornato da 4.4.0 a 4.4.8 e poi 4.5.2 su Ubuntu 16.04 LTS a 64 bit, e sta ancora accadendo.

A 4.5.2 è ancora più frequente, e principalmente in Chrome (non ho ancora provato Firefox o Opera). Ogni volta che apro una nuova pagina web. Qualche modo per risolverlo, o è un bug?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

Saluti.


196
2018-05-03 06:31


origine


La stessa cosa che ho sperimentato su Ubuntu 14.04.4 - Billal Begueradj
Sto anche affrontando lo stesso problema, specialmente durante l'utilizzo di Facebook. È troppo fastidioso - sgiri
Provare --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers   alcune informazioni extra qui: productforums.google.com/forum/#!topic/chrome/... - Postadelmaga
Googler qui. Questo bug viene tracciato nel tracker dei problemi di Chromium all'indirizzo # 606152 - Sfarfallio su Intel con upload a una copia. - Dan Dascalescu
Sono passato allo stack HWE (kernel 4.8 e X-7.7). Ha fermato il rumore. C'è qualche problema con i915 (Driver Intel HD Graphics) nella serie del kernel 4.4. - Manoj Sawai


risposte:


Dopo alcune ricerche, ho trovato una soluzione a questo problema. Funziona per me ora.

Ho disabilitato l'accelerazione hardware per il mio browser da

Settings > Advance Settings > System > uncheck the hardware acceleration

Spero che funzioni sulla tua macchina.


sto usando google-chrome-stable Version 50.0.2661.94 (64-bit) sopra Ubuntu 16.04

-----MODIFICARE----

Se incontrate ritardo di scorrimento e rottura dello schermo. Fai come suggerito da Amos Folarin nel commento qui sotto:

Vai a: chrome://flags/#smooth-scrolling e abilitalo.


186
2018-05-05 17:54



L'ho provato, risolve il problema ma rallenta lo scorrimento e lo schermo. - Mookey
Questo in realtà non dovrebbe essere accettato, in quanto non è una soluzione, è sicuramente un work-around. - theV0ID
Questo non ha alcun effetto sullo sfarfallio per me. - DavidJ
Questa soluzione ha funzionato con il mio XPS13 9343, lo sfarfallio si è fermato definitivamente o non è evidente. Ho anche provato l'altra soluzione suggerita qui impostando chrome: // flags / # enable-gpu-rasterization su 'Force-enabled for all layers' ma questo non ha funzionato, solo disabilitare l'accelerazione hardware in chrome sembrava funzionare. Ma d'accordo con @ theV0ID che la sua non è idea. - Amos Folarin
Prova anche a abilitare chrome: // flags / # scrolling scorrevole per uno scorrimento uniforme. Sto usando XPS13 + Ubuntu16.04 funziona bene con l'opzione di accelerazione hardware deselezionata - Amos Folarin


Ho avuto lo stesso problema, l'impostazione della rasterizzazione della GPU su "Forza-abilitata per tutti i livelli" sembra essere finalmente funzionante:

Chrome Flags: GPU rasterization


158
2017-08-08 07:52



link rapido: chrome: // flags / # enable-gpu-rasterization - JohannesNE
ha funzionato anche per me - Sufiyan Ghori
Ha smesso di funzionare, lo sfarfallio è tornato, penso dopo l'aggiornamento alla versione 53.0.2785.92 di Chrome (64-bit) - Omid
Ciò riduce drasticamente lo sfarfallio, ma è ancora presente in Google Inbox, ad esempio (attualmente l'unico posto in cui lo vedo). - TiGR
Funziona, ma ora viene visualizzato solo l'angolo in alto a sinistra di alcune immagini. Ciò che per me è stato Chrome: // flags / # ignore-gpu-blacklist - Jasny - Arnold Daniels


Apri un terminale e inserisci questo comando:

sudo nano /usr/share/applications/chromium-browser.desktop

e scorrere verso il basso fino a raggiungere questa linea:

Exec= chromium-browser

Quindi aggiungi questi due parametri

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Premi Ctrl + O per salvare e Ctrl + X per uscire.

Quindi inserisci questo comando:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

e aggiungi queste linee

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Premi Ctrl + O quindi Ctrl + X.

Apri Chromium e scrivi sulla barra degli indirizzi: chrome://flags/ ed entra

  • Abilita zero-copy
  • Abilita Sostituisci elenco di rendering del software
  • Abilita Mostra Canvas lista 2D

Finalmente apri le impostazioni di Chrome e fai clic su:

  • Usa l'accelerazione hardware quando disponibile

38
2017-07-27 08:10



Ha funzionato con la mia CPU Intel® Core i7-6700HQ Dell XPS 15 95050 a 2,60 GHz Intel® HD Graphics 530 (Skylake GT2). - Prydie
Nel mio caso (dopo aver provato più soluzioni) ho semplicemente abilitato quelle bandiere che hai menzionato (zero-copy, Override Software Rendering List, Display 2D List Canvas) e sembra averlo risolto (su Intel HD Graphics). - Nahuel
I due switch della riga di comando (disabilita soluzioni alternative / abilita i buffer nativi di memoria gpu) non sembrano funzionare più, ma creano il 20-intel.confil file ha funzionato per me! Abilitato anche la rasterizzazione gpu (non sono sicuro se sia importante). - terabaud
L'unica soluzione funzionante per me. Grazie - Darkside
Solo aggiungendo 20-intel.conf ha funzionato per me - non doveva fare nient'altro. - Vadi


L'ho risolto come segue:

sudo apt-get purge xserver-xorg-video-intel

quindi riavviare. Questo perché i driver Intel sono passati alla modalità. Per maggiori informazioni vedi questo commento nella discussione del bug di Chromium.


37
2017-08-19 14:25



Ho seguito la rotta chrome flags e poi sono andato su questa rotta e ho resettato i flag su default e cancellato il contenuto di Intel. Fin qui tutto bene. - Sethen
Grazie. Ho un Intel NUC che ha pochi anni e ha subito alcuni aggiornamenti. È il 16.04.2 ma il tuo suggerimento ha trovato pacchetti da eliminare. Non lampeggia più (il mio video HDMI era acceso e spento a circa 1 o 2 Hz dopo alcuni aggiornamenti recenti, ho pensato che avesse sviluppato un guasto hardware dopo 8 anni di servizio). - Tim Richardson
Questa risposta dovrebbe essere molto più alta! - Galgalesh
Questo è? Funziona perfettamente !!! Risposta totalmente sottovalutata. Grazie mille amico! - uloco
Grazie! Questo ha risolto il problema per me. La tua risposta dovrebbe essere alcuni punti più in alto di quello che è. - Anthony D.


Nessuna di queste risposte sembrava aiutarmi. Quello che ho finito per fare quale sembra averlo risolto (il mio riferimento era questo sito http://www.bang-olufsen.com/ che tremava come CRAZY e ora funziona senza problemi) è questo:

1.- Navigato verso chrome://gpu/. Questo è quello che ha mostrato:

enter image description here

2.- Ho provato a risolvere i problemi uno per uno. Nel mio caso, l'abilitazione di questi flag ha risolto alcuni di essi: GPU rasterization, Override software rendering list. Quindi ha mostrato così:

enter image description here

3.- Ho modificato il launcher desktop e aggiunto i parametri --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers.

4.- Dopodiché, non vengono più rilevati problemi, tutto viene visualizzato come "hardware accelerato" e, cosa più importante, non c'è più sfarfallio:

enter image description here

Se prima aggiungi i parametri al programma di avvio, l'elenco dei problemi dovrebbe essere più breve e probabilmente sarà più facile capire quali flag ti aiuteranno con i problemi che ti rimangono.


24
2017-09-14 12:29



Questa è una buona referenza. L'ho usato per risolvere il mio problema con Firefox, dove è stato semplicemente risolto deselezionando la casella "Usa accelerazione hardware" nelle impostazioni avanzate. - Bach
Questo ha ridotto lo sfarfallio per me, ma succede ancora spesso ... - addison


Con Chrome versione 51.0.2704.103 (64-bit) i flag

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

non funziona più

Il modo migliore che possiamo fare è tornare a Chrome 50 (versione 50.0.2661.86 (64-bit)), ecco un'istruzione su come puoi fare un passo indietro: come faccio a eseguire il downgrade di google chrome? 

Importante è che facciamo pressione su Google per risolvere questo problema, votare per il bug in Chromium e nella pagina del prodotto di Google:

https://bugs.chromium.org/p/chromium/issues/detail?id=606152

https://productforums.google.com/forum/#!topic/chrome/CtKF2BiskT8;context-place=forum/chrome


7
2018-06-19 08:02



Non funziona per me. - ComBin
@ComBin: hai provato a tornare alla v50 e usato le bandiere? Tuttavia, segui il link al bug chromium ci sono un sacco di diverse proposte di soluzioni per far funzionare questa versione corrente di chrome / -ium. - user157697
non voglio v50, grazie. Sono trovato il modo migliore per risolverlo, vedere la mia risposta qui sotto. - ComBin
AHa, nel bug cromo, i ragazzi volevano dire che questo avrebbe avuto enormi problemi di prestazioni. Comunque proverò qualche suggerimento dai bug di cromo quando avrò il tempo, per quanto ho capito il Chromium è solo il sintomo non la causa. Ti terrò aggiornato se trovo qualcosa di meglio / altro. Saluti. - user157697


chrome://flags/ > GPU rasterization > Enable,

Questo alla fine ha funzionato per me! Trovato in fondo a questo modulo di Google! https://productforums.google.com/forum/#!msg/chrome/CtKF2BiskT8/dLXKfU2XAQAJ


5
2017-10-16 20:44





Penso di aver trovato la soluzione:

flags --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffer e anche enable-zero-copy ENABLE

    sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf
    Section "Device"
       Identifier  "Intel Graphics"
       Driver      "intel"
       Option      "AccelMethod"  "sna"
       Option      "TearFree"    "true"
       Option      "DRI"    "3"
    EndSection

4
2017-07-07 15:14



Mancano alcune bandiere, ecco il mio passo dopo passo: bugs.chromium.org/p/chromium/issues/detail?id=606152#c72 - Hermann Bier
Sono stato in grado di risolvere il mio problema con solo la Sezione nel file 20-intel.conf senza bandiere aggiuntive in chrome su beatrion bionico 18.04 - Brandon Søren Culley


Prova a caricare con alcune opzioni della GPU disabilitate:

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffer

Dopo aver provato, puoi anche giocare con alcune delle impostazioni di rendering in about: // flags e vedere se qualcosa aiuta, ma la maggior parte dei miei sfarfallio di rendering sono stati risolti dai due flag della riga di comando. Se si dispone di un file .desktop di avvio, aggiungere tali flag all'inizio della voce Exec prima di '% U'. È inoltre possibile aggiungerli alle altre voci di Exec per fare in modo che i flag vengano applicati a tutte le modalità di avvio.


2
2018-05-04 15:44