Domanda Clementine non riproduce .wma, con errore "La tua installazione di GStreamer manca un plugin"


Ecco uno screenshot: enter image description here

Mostra messaggi come: "Clementine si è fermato." o visualizza i brani che non vengono riprodotti e l'icona dell'indicatore scompare e riappare. Questo succede solo a me, o è un bug comune in 14.04. Ho pulito installato 14.04, e nel 13.10 la clementina ha funzionato bene. Qualche idea? Ho installato ubuntu-restricted-extras.

Modifica1: ho riavviato il computer e il tema è cambiato: enter image description here enter image description here

Edit2: Ho appena capito che la clementina non riproduce i file .wma, e in quel momento iniziano ad emergere errori.

Edit3: VLC e il lettore ubuntu predefinito riproducono .wma senza problemi. Per favore aiuto!


33
2018-04-26 22:53


origine


Hai i pacchetti gstreamer0.10-plugins-good, gstreamer0.10-plugins-bad e gstreamer0.10-plugins-brutto installati? - fossfreedom♦
Sì, dice che sono la versione più recente. - Dusan Milosevic
che tipo di musica stai cercando di suonare? per esempio. mp3? - fossfreedom♦
Sto riproducendo file mp3 e ogg, ma Clementine li suona. Il problema sono i bug descritti. - Dusan Milosevic
se si tratta di bug, dovresti segnalarli su launchpad per consentire agli sviluppatori di visualizzare i problemi. - fossfreedom♦


risposte:


14.04 e successive

Ho controllato la clementina 1.2.x. dipendenze e posso confermare che richiede i plugin gstreamer 0.10 e poiché il supporto wma è fornito dal plugin ffmpeg è necessario configurare il seguente PPA per abilitare il supporto WMA per 14.04 e successivi:

sudo add-apt-repository ppa:mc3man/gstffmpeg-keep
sudo apt-get update
sudo apt-get install gstreamer0.10-ffmpeg

50
2018-04-27 08:46



Ecco cosa ottengo: 'Leggere gli elenchi dei pacchetti ... Fatto Costruire l'albero delle dipendenze Leggere le informazioni sullo stato ... Fatto gstreamer1.0-plugins-good è già la versione più recente. gstreamer1.0-libav è già la versione più recente. gstreamer1.0-plugins-bad è già la versione più recente. gstreamer1.0-plugins-brutto è già la versione più recente. I seguenti pacchetti sono stati installati automaticamente e non sono più necessari: kde-l10n-engb kde-l10n-sr Utilizzare 'apt-get autoremove' per rimuoverli. 0 aggiornato, 0 appena installato, 0 da rimuovere e 1 non aggiornato. ' - Dusan Milosevic
Ora funziona! Grazie mille! - Dusan Milosevic
Grazie per questa soluzione. Ha funzionato perfettamente anche per me! - Adam Brisebois
@ Sardinha94410: Ho aggiornato la mia risposta per utilizzare un ppa abilitato per 14.10 - Sylvain Pineau
@chtfn: Grazie per il tuo consiglio (e la conferma che funziona per 14.04). Risposta aggiornata - Sylvain Pineau


A proposito, nella mia Ubuntu 14.04 (aggiornato alla 13.10) sembra che non ci sia apt-add-repository

sudo apt-get install software-properties-common

Ora sì, è possibile installare gstreamer0.10-ffmpeg come # 1 ha detto:

sudo apt-add-repository ppa:mc3man/trusty-media
sudo apt-get update
sudo apt-get install gstreamer0.10-ffmpeg

4
2018-04-29 08:09



Strano perché software-properties-common fa parte dei pacchetti installati di default (Vedi 13.10 manifesto) - Sylvain Pineau


Stavo ricevendo questo errore su 14.04 LTS quando provavo a trasmettere qualsiasi sorgente internet. Questo è ciò che ha risolto l'errore per me:

sudo apt-get install gstreamer1.0-libav

2
2018-05-25 19:27





Ho avuto lo stesso problema con Clementine e Ubuntu 16.04, anche se tutto funzionava bene prima, ma improvvisamente le canzoni di m4a si sono fermate per funzionare.

Apro un singolo file usando l'applicazione video ubuntu predefinita che mi suggerisce di installare gstreamer1.0-plugins-bad-faad 

così questo comando ti può aiutare

$ sudo apt install gstreamer1.0-plugins-bad-faad


1
2018-02-14 10:18



Questo ha funzionato per me. - Mincă Daniel Andrei