Domanda Tastiere bloccate in IntelliJ IDEA su Ubuntu 14.04


Potresti aiutarmi con una questione strana? Uso Intellij IDEA 13 su Ubuntu 14.04 e di volta in volta la mia tastiera completamente (sì, completamente, non si tratta di scorciatoie) blocchi in IDEA. Posso ancora fare tutto ciò che voglio in IDEA con il mio mouse, inoltre posso usare la tastiera ovunque tranne IDEA. E può essere risolto solo riavviando IDEA finora.

Qualcuno può dare un suggerimento, per favore?


165
2017-07-24 06:58


origine


Può essere che la tua tastiera venga semplicemente catturata da un campo all'interno di IntelliJ? È una cosa casuale o fa qualcosa di specifico che lo innesca? - Ruraj
Non penso che un campo possa catturare una tastiera del genere, ma la controllerò più precisamente la prossima volta. E sembra essere una cosa casuale. - Treble Snake
Il mio collega e io stiamo sperimentando esattamente la stessa cosa (stesso OS e IntelliJ 13.1.4). Devo riavviare IntelliJ una volta ogni poche ore (sono in grado di usare Alt-F4, però) - estremamente fastidioso. Trovo anche che avvenga in modo completamente casuale. L'ultima volta ero nel mezzo della modifica di un file HTML. Non mentre si preme una scorciatoia. - Halle Knast
Avevo due istanze di IntelliJ in esecuzione e si bloccarono entrambi. Non so se è rilevante, ma quando chiudo l'IDE, il distacco di un server delle applicazioni in esecuzione richiede normalmente molto poco tempo. Dopo un congelamento, devo cancellarlo perché non sembra che finisca. - Halle Knast
Questo è un problema Java che influisce su altre GUI di Java Swing, inclusa l'interfaccia utente SOAP. "ibus-daemon -rd" risolve anche il problema - rjdkolb


risposte:


C'è un un problema aperto in jetbrains youtrack per idea intellij che consiglia due soluzioni:

  1. L'input della tastiera può essere sbloccato riavviando il demone IBus da una console:

    ibus-daemon -rd
    
  2. IBus può essere disabilitato per IDEA disabilitando env. XMODIFICATORI variabili, ma la capacità di inserire caratteri nazionali in IDEA andrà persa:

    XMODIFIERS="" idea.sh
    

Ho usato il secondo e risolto il mio problema.


206
2017-10-18 16:50



> "ibus-daemon -rd" da una console. Ha funzionato! Fantastico, grazie!) - Treble Snake
6 mesi dopo, l'opzione 1 non è più consigliata in quanto potrebbe causare un arresto anomalo di JVM: / - mike
Cosa intendi per personaggi nazionali, @ Mike, ha funzionato per me oggi, il 2 giugno - Abderrahmane TAHRI JOUTI
"ibus-daemon -rd" - Sto seriamente pensando di tatuarlo sul mio braccio. - Balázs Mária Németh
L'ultimo aggiornamento sul problema (17 giugno 2015) consiglia di export IBUS_ENABLE_SYNC_MODE=1 - Nacho Coloma


Sono stato in grado di risolverlo con quello che ho trovato Qui questo è fondamentalmente l'aggiunta export XMODIFIERS="" sopra idea.sh


14
2018-03-05 16:45



sembra lavorare qui! - Marc Hauptmann


Per un soluzione permanente, il  Aggiornamento dell'01 ottobre 2015 sul problema raccomanda di:

Aggiornare IBus alla versione 1.5.11 o aggiungere export IBUS_ENABLE_SYNC_MODE=1 alla tua ~/.profile, quindi riavviare una sessione.

In alternativa, puoi disattivare IBus a System Settings | Language Support | Keyboard input method.

IDEA 15 mostrerà un avviso se è in uso una versione incompatibile di IBus.


5
2017-11-30 11:53





Ho provato questo e il suo funzionamento finora, ma aggiornerò se si blocca di nuovo. Ho visto un suggerimento su youtrack che suggerisce di disattivare iBus che sembra interferire in particolare a causa dell'uso del collegamento ctrl + spazio per modificare le impostazioni della lingua. Puoi farlo andando a:

supporto lingua> sistema metodo di immissione tastiera> nessuno

enter image description here

**** AGGIORNARE *****

Dopo averlo eseguito per un po ', questa tecnica non funzionava ancora perché continuavo a congelare. Immagino per ora che seguirò la seguente soluzione alternativa per riavviare ibus, che è un po 'scomodo, ma cosa puoi fare.

andare in terminal

genere:

ibus-daemon -rd

1
2018-04-05 00:33



Grazie, ibus-daemon -rd è quello che stavo cercando. - Lambart