Domanda Come posso installare Adobe AIR?


Sono un utente pesante di alcune applicazioni che sono costruite su AIR.

Sembra che AIR abbia interrotto il supporto per Linux. Anche le versioni precedenti negli archivi Adobe AIR sembrano supportare solo distribuzioni Linux a 32 bit e attualmente sono a 64 bit.

C'è anche una leggera possibilità che io possa eseguire AIR in queste condizioni? In tal caso, può dirmi dove posso ottenere un'installazione dettagliata e dettagliata per questo?


153
2017-12-13 14:51


origine


Nota che Adobe ha terminato il supporto per AIR su Linux. Adobe si sta inoltre allontanando dalle tecnologie legacy come Flash e AIR in HTML5, che è il futuro. - Anonymous
Ho installato adobe air dal file .deb in oneric - Tachyons


risposte:


Ho bisogno di Air per circa tre programmi: YNAB, LongTailPro, Xtend:

  1. Scarica l'ultima versione di Air 2.6.0 per Linux sul tuo desktop:

  2. Ctrl + Alt + T per aprire il terminale

  3. sudo apt-get install ia32-libs  - (32 bit di spazzatura se vuoi eseguire questo in Ubuntu x64, se hai problemi, vedi "Dipende: ia32-libs-multiarch ma non è installabile" - Soluzione)

  4. cd Desktop (cambia dir. nella cartella Desktop).

  5. chmod +x AdobeAIRInstaller.bin (cambia modalità - esegui permessi si)

  6. ./AdobeAIRInstaller.bin (dopo aver accettato la licenza Adobe Air, ti verrà richiesta la password, ma è necessario l'accesso come root per l'installazione)

Forse riceverai un errore dopo l'ultimo comando?

Spiacenti, si è verificato un errore. Adobe AIR non può essere installato. Installa Gnome Keyring o KDE KWallet prima di installare Adobe AIR.

Questo può essere risolto:

  • In un terminale (scorciatoia predefinita: Ctrl + Alt + T), digitare:

    locate libgnome-keyring.so
    
  • Questo è il mio risultato (il tuo potrebbe essere diverso):

    /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0
    /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0
    
  • Come suggerito di seguito da @jmendeth, il modo più semplice per dire al programma di installazione dove trovare questi file è utilizzare LD_LIBRARY_PATH:

    • Per Ubuntu a 32 bit (testato il 12.04):

      LD_LIBRARY_PATH=/usr/lib/i386-linux-gnu ./AdobeAIRInstaller.bin
      
    • Per Ubuntu a 64 bit, la riga di comando sarebbe probabilmente:

      LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu ./AdobeAIRInstaller.bin
      

Se il trucco LD_LIBRARY_PATH non funziona, puoi provare questo:

  • Crea un collegamento simbolico alle stringhe di posizione che hai trovato con i comandi precedenti:

    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
    
  • Utilizzare i seguenti comandi per i sistemi a 32 bit:

    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
    
  • Quindi ripeti i passaggi 4 e 6 (salta 5, poiché il permesso di eseguire il file non è cambiato).

  • Rimuovere i collegamenti simbolici dopo l'installazione di Adobe AIR 2.6.0:

    sudo rm /usr/lib/libgnome-keyring.so.0
    sudo rm /usr/lib/libgnome-keyring.so.0.2.0
    

Riferimento:


225
2018-04-09 02:26



Grande! È installato Ora se posso installare solo un pacchetto AIR ... - BrianXP7
Non rispetta l'ARIA LD_LIBRARY_PATH? Basta chiedere - Alba Mendez
Ho creato un account solo per aggiornare questo +1 - Paul Bellora
Non posso fare +1 su abbastanza. - Jonah
Non funziona per me su Xubuntu 13.10. sudo apt-get install ia32-libs Il pacchetto ia32-libs non è disponibile, ma viene chiamato da un altro pacchetto. Ciò potrebbe significare che il pacchetto è mancante, è stato obsoleto o è disponibile solo da un'altra fonte. Tuttavia i seguenti pacchetti lo sostituiscono: lib32asound2 lib32z1 lib32ncurses5 lib32bz2-1.0 ./AdobeAIRInstaller.bin /tmp/air.kmEATV/setup: errore durante il caricamento delle librerie condivise: libgtk-x11-2.0.so.0: impossibile aprire il file oggetto condiviso: No tale file o directory - Slava Fomin II


Ubuntu 13.10, 14.04, 15.04 e 15.10 (64 bit)

  1. Installare le librerie i386, necessarie per l'installazione e l'esecuzione di applicazioni Adobe Air e Air.

    sudo apt-get install libxt6:i386 libnspr4-0d:i386 libgtk2.0-0:i386 libstdc++6:i386 libnss3-1d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libcanberra-gtk-module:i386 gtk2-engines-murrine:i386
    
  2. Installare libgnome-keyring0:i386 pacchetto.

    sudo apt-get install libgnome-keyring0:i386
    
  3. Crea collegamenti simbolici a gnome-keyring in modo che Adobe Air possa vederlo.

    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
    
    sudo ln -s /usr/lib/x86_64-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0 
    
  4. Scarica il programma di installazione di Adobe Air da Qui.

  5. Dai il permesso di esecuzione e poi esegui quel file .bin.

    sudo chmod +x AdobeAIRInstaller.bin
    sudo ./AdobeAIRInstaller.bin
    

fonte

Nota per Ubuntu 16.04 (64 bit)

Per Ubuntu 16.04 e versioni successive, installare il pacchetto libnss-mdns:i386 invece del pacchetto lib32nss-mdns. Questo risolverà il problema di "Errore non trovato nel pacchetto" relativo a quel pacchetto.


43
2018-03-28 23:36



Questo funziona anche per 14.04 - adosaiguas
Buono a sapersi ... aggiornerò la mia risposta. - Avinash Raj
Questo funziona anche per 15.04 (64 bit). Grazie. - Dmitry Wojciechowski
Funziona anche per 15.10 (sto usando la versione di sviluppo) - Yana Agun Siswanto
16.04, ho ricevuto un errore lib32nss-mdns mancava. Quando è stato aperto l'installatore Gtk-Message: Failed to load module "overlay-scrollbar" Gtk-Message: Failed to load module "gail" Gtk-Message: Failed to load module "atk-bridge". Sembra aver installato correttamente. Ma l'app di cui avevo bisogno per AIR ha bisogno di una versione più recente: / - raphael


In alternativa, puoi installare un .deb precostruito

C'è air 2.6 (l'ultimo Linux supportato) disponibile Qui per entrambe le architetture (entrambi usano 32 bit al di sotto ma almeno funziona). Grazie a prusswan per indicarlo.

Assicurati di avere librerie a 32 bit di cui avrà bisogno:

sudo apt-get install ia32-libs

Ho scaricato l'AMD64 (adobeair_2.6.0.19170_amd64.deb) e installato sul mio computer (am64 con Precise Pangolin 12.04)

sudo dpkg -i adobeair_2.6.0.19170_amd64.deb

Quindi ho installato l'applicazione che aveva bisogno di Adobe Air in primo luogo e ha funzionato.

Aggiornamento per Ubuntu 13: 10+,

Provando questa tecnica, ricevo "Pacchetto ia32-libs-gtk non installato"

Ho cercato il pacchetto e ho provato a installare quelle dipendenze e altri pacchetti correlati a cui posso pensare direttamente:

sudo apt-get install gtk2-engines:i386 libart-2.0-2:i386 libcairo2:i386 libcanberra-gtk0:i386 libdatrie1:i386 libgail-common:i386 libgconf2-4:i386 libgtk2.0-0:i386 liblua5.1-0:i386 libpango1.0-0:i386 libpixman-1-0:i386 libqt4-network:i386 libqt4-test:i386 libqtcore4:i386 libthai0:i386 libbonobo2-0:i386 libglade2-0:i386 libgnomecanvas2-0:i386 libidl0:i386 liborbit2:i386 libwmf0.2-7:i386 gtk2-engines-murrine:i386

Ma questo non ha funzionato né per il deb né per binario originale.


18
2018-05-29 19:56



Ho cercato su internet in alto e in basso e il tuo link di installazione è l'unico che ha funzionato. Nota per i futuri visitatori: se usi AdobeAIRInstaller.bin e ottieni un Gtk WARNING **: cannot open display: errore, prova questo! - eleanor.mal
questo è molto più facile di jeffhendricks.net/?p=68 - realgt
Scavò un po 'più a fondo di Nora e trovò la risposta riguardo al problema "Impossibile aprire il display". Il problema è che non è possibile connettere l'utente root allo schermo X in Ubuntu (con le impostazioni predefinite), ma è necessario eseguire il nostro programma di installazione come root (fail-design). Prima installa sux (switchuser con credenziali X). Consenti all'utente root di connettersi alla visualizzazione X. Ottieni le impostazioni correnti del display. Quindi utilizzare sux per passare all'utente root. Esegui il programma di installazione con le impostazioni del display. 1. sudo apt-get install sux 2. /usr/bin/xhost + 3. echo $DISPLAY (utilizzare questo al punto 5) 4. sudo sux - 5. DISPLAY=:0.0 ./AdobeAIRInstaller.bin - Nicholi


Ubuntu 14.04 - 32 e 64 bit - facile installazione .deb

A causa del modo in cui il multiarch funziona, ora puoi semplicemente installare il file .deb i386 sul nuovo Ubuntu a 64 bit e installerà automaticamente le giuste dipendenze. (Anche il 64 bit .deb è solo il repackaged a 32 bit con una dipendenza da ia32-libs)

  1. Scarica il deb di 32 bit (sì anche per il tuo Ubuntu a 64 bit): http://update.devolo.com/linux/apt/pool/main/a/adobeair/adobeair_2.6.0.19170-devolo1_i386.deb (Grazie alla risposta di yuvilio) Il pacchetto a 64 bit sullo stesso sito è una versione riconfezionata del 32 bit, si avranno problemi se si utilizza invece il pacchetto a 64 bit, si usi il pacchetto a 32 bit per i sistemi a 32 e 64 bit di Ubuntu 13.10+.

  2. Aprire nel centro del software, fare clic Installare

    enter image description here Ignora l'avviso sulla qualità del pacchetto


In alternativa, se hai un gioco Steam che richiede Air, semplicemente installa ed esegui quel gioco e installerà Air alla prima esecuzione del gioco.

Esempi di giochi che usano Air:

  • Difensori Quest
  • Anodyne (si confonde se hai già installato Air, corri sudo apt-get remove adobeair e prova di nuovo l'installer del gioco dato che arriva con Air)

Ho trovato questi durante un Vendita umile settimanale supportare alcuni progetti open source.


13
2018-03-30 11:46





Step 1: Prendi un po 'd'aria Successivamente scarica il file Adobe Air .bin (link diretto qui).

Passaggio 2: installazione

Aprire un terminale (applicazioni> Accessori> Terminale) e accedere alla cartella Download (o alla cartella in cui è stato salvato il file .bin).

* cd Download/

Abbiamo bisogno di lasciare che il file .bin abbia le autorizzazioni per l'installazione, quindi inserisci attentamente il seguente comando: -

* chmod +x AdobeAIRInstaller.bin

Ora consente di installarlo:

* ./AdobeAIRInstaller.bin

L'installazione dovrebbe comprimere e, se tutto va bene, una nuova voce di menu apparirà in "Applicazioni> Accessori" intitolato "Adobe Air Application Installer".


6
2018-01-10 04:14



Questo non funziona su Ubuntu 13.10 x64 - Paul Gregoire


... finalmente dopo qualche problema e dopo molte ricerche su questo forum, Google e altre pagine sono riuscite a farlo. Innanzitutto voglio ringraziare la comunità che mi ha dato più ambizione di farlo, piuttosto che farmi chiudere l'installazione di AdobeAir.

L'intero problema era il pacchetto ia32-libs(Il pacchetto ia32-libs era un trucco per ottenere pacchetti a 32 bit installati su un'installazione a 64 bit. Dalla versione 11.10 di Ubuntu (Oneiric), è stato aggiunto Multi Arch. Uno degli obiettivi è la rimozione del pacchetto ia32-libs) ... pacchetto che Canonical ha deciso di terminare con il supporto.

Tutto quello che dovevo fare per installare ia32-libs il pacchetto era di aggiungere questo repo:

1- ''debuttante http://archive.ubuntu.com/ubuntu/ fonte rara di multiversepackage dell'universo ristretto e raro''

Ho seguito i passaggi di questo tutorial semplice e veloce:

http://wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10

2- allora questa pagina che mi porta a questo bello passaggi per installare Adobe Air per sistemi a 64 bit

www.thepowerbase.com/2013/06/how-to-install-adobe-air-in-ubuntu-13-04/

-----------------documentazione che ho usato:---------------

www.askubuntu.com/questions/87447/how-can-i-install-adobe-air
helpx.adobe.com/air/kb/archived-air-sdk-version.html
www.wiki.phoenixviewer.com/ia32-libs-in-ubuntu-13-10
www.ubuntuforums.org/showthread.php?t=2181649
www.askubuntu.com/questions/91815/how-to-install-software-or-upgrade-from-old-    unsupported-release  

Post scriptum --- come notato da Alvar, Adobe Air per Linux non è più supportato ---


4
2017-11-06 09:08



Dai un'occhiata a questo link. Ha funzionato bene. tkalin.com/blog_posts/... - Michael Mikowski
@MichaelMikowski Il tuo link mi ha aiutato. I link sopra non avevano una soluzione di libreria di coping manuale che non poteva essere installata. Successivamente, ho installato AdobeAir. - ubuntico


Sfortunatamente, molti anni dopo "Adobe AIR per Linux non è più supportato." seguendo ciò che dice la pagina di Adobe. Utilizzando l'archivio "AIR" è possibile ottenere versioni non supportate, la versione 2.6.0 è la più recente disponibile. Se è necessario installare un programma che richiede una versione più recente, è possibile passare a Virtual box con un guest Windows.

I passaggi consigliati per Ubuntu 16.10:

per macchina a 32 bit

wget -O adobe-air_i386.deb http://drive.noobslab.com/data/apps/AdobeAir/adobeair_2.6.0.2_i386.deb
sudo dpkg -i adobe-air_i386.deb
sudo apt-get install -f && rm adobe-air_i386.deb

per macchina a 64 bit

wget -O adobe-air_amd64.deb http://drive.noobslab.com/data/apps/AdobeAir/adobeair_2.6.0.2_amd64.deb
sudo dpkg -i adobe-air_amd64.deb
sudo apt-get install -f && rm adobe-air_amd64.deb

I passaggi consigliati per Ubuntu 16.04 / 14.04 / 12.04 / Linux Mint 18/17/13 (entrambi estratti da Qui):

wget -O adobe-air.sh http://drive.noobslab.com/data/apps/AdobeAir/adobe-air.sh
chmod +x adobe-air.sh;sudo ./adobe-air.sh

1
2018-03-30 17:53





Ho Ubuntu 14.04 a 64 bit. L'unico modo per installare Adobe Air che funzionava per me era seguire la prima parte di questi istruzioni per l'installazione di Balsamiq su Ubuntu, che è quello che stavo cercando di fare in primo luogo.

Un breve riassunto di queste istruzioni: - Scaricare questo programma di installazione di Adobe Air - Installazione del pacchetto libgtk a 32 bit (ma ho saltato questo passaggio, non ha funzionato per me e non mi è sembrato necessario) - Creazione di collegamenti simbolici a due file di portachiavi libgnome - Rendere eseguibile il programma di installazione Adobe Air e eseguirlo con sudo


0
2018-01-29 22:46