Domanda remmina non funziona più "impossibile connettersi al server locale RDP"


Fino a qualche tempo fa la scorsa notte, avevo remmina funzionante. Potrei eseguire RDP attraverso un tunnel SSH e tutto andava bene.

Poi ha smesso di funzionare. Posso arrivare fino alla finestra di dialogo della password per la mia macchina da lavoro, ma poi dice semplicemente Cannot connect to RDP server localhost.

Non riesco nemmeno a trovare i log che sembrano interessanti. Ho reinstallato Remmina, cancellato il mio .remmina directory, riavviato il mio computer e persino riavviato il mio gateway.

Solo per renderlo davvero strano, il mio laptop (che ha la stessa configurazione - l'ultima di Ubuntu e Remmina) può rendere la connessione perfetta. Attraversa lo stesso router, anche se in modalità wireless.

qualche idea?


27
2017-09-26 20:29


origine


Affronto lo stesso problema su Ubuntu 18.04 e funziona perfettamente una volta ho cambiato l'opzione di sicurezza da negoziare in RDP dalla scheda precedente. - Paras


risposte:


Non ho idea del motivo per cui ha funzionato, ma ho iniziato a modificare le impostazioni una alla volta. Quando ho modificato le proprietà della connessione, ho cercato la scheda "avanzata" e ho cambiato la sicurezza da "negoziare" a "TLS", e voilà, tutto funziona.

Stranamente, "negoziare" funziona ancora sul laptop, ma almeno sono tornato in affari con il mio monitor più grande :)


38
2017-09-26 22:15



Dopo aver cambiato da "negoziare" a "TLS", ho visto la schermata di accesso a Windows che mi ha spinto a cambiare la password. Quindi sembra che le password scadute possano riguardare il problema. Grazie per la soluzione. - Thorsten Niehues


Mi è appena successo e ho trovato questa risposta che ha risolto il problema. Appena rm ~/.freerdp/known_hosts e prova ancora.

Apparentemente ciò accade quando cambiano le chiavi sul server del tunnel. Vedere questo bug.

AGGIORNARE

Il primo link ora punta a una risposta cancellata, quindi ecco alcune delle informazioni aggiuntive da quel link:

  • Sembra che il file "known_hosts" contenga alcuni dati di routing per ciascun server, che a volte i dati diventano obsoleti e quando Remmina   prova a connettersi usando i dati obsoleti, fallisce. Cancellare il   Il file known_hosts risolve questo problema. - Erel Segal-Halevi 13 dicembre 12   alle 10:06

  • FWIW, il mio problema non aveva nulla a che fare con known_hosts (come spiegato in seguito), ma tutto ciò che ha a che fare con le impostazioni di sicurezza: vedi    http://www.bauer-power.net/2013/10/unable-to-connect-to-rdp-server-in.html   per dettagli. - Tomislav Nakic-Alfirevic 24 aprile 14 alle 10:58

  • Completamente lavorato, mi stavo chiedendo dove venivano conservati i certs. Ho avuto lo stesso problema per la maggior parte, stava usando Remmina a RDP per un certo   macchina, poi un giorno ha smesso di funzionare (niente sul telecomando   macchina cambiata). Altre connessioni RDP che avevo salvato funzionavano ancora,   tranne per questa macchina. È capitato di usare l'autenticazione NLA, che   sembra essere parte del problema con il nuovo Remmina che non salva   certs. - Nicholi 26 aprile 13 alle 20:26

  • grazie, si collegava perfettamente quindi ho riformattato il server e ha smesso di funzionare, cancellando la linea per questo host ha funzionato. -   Bor691 15 gennaio 14 alle 8:50

  • Ho bisogno di utilizzare due servizi sullo stesso indirizzo ma porte diverse e usarlo ripetutamente è l'unico modo in cui posso connettermi a entrambi. -   Gringo Suave 13 ottobre 14 alle 18:55


37
2017-08-08 08:33



È stato suggerito di aggiungere sudo di fronte a rm comando. Per quanto vedo, l'utente rimuove il proprio file, quindi sudo solo il rischio di pubblicità. Mi sto perdendo qualcosa? - Volker Siegel
Capisco che questa è una vecchia domanda e risposta. Uno dei motivi per cui non ho mai pubblicato un link esterno come risposta o in una domanda è perché dopo qualcosa che il collegamento potrebbe essere MORTO come in questo caso. Quando ciò accade, la risposta potrebbe diventare inutile. Sto solo indicando l'ovvio o StackOverflow dovrebbe impedire agli utenti di questo sito Web di pubblicare link esterni. - ThN
Per vostra informazione, il file in questione sembra essere ora in ~ / .config / freerdp / known_hosts - almeno è sul mio sistema (Linux Mint 18.1). C'è anche un ~ / .config / freerdp / known_hosts2 che contiene informazioni aggiuntive che potrebbero essere più aggiornate. Remmina 1.20. - Chris Hillery


Questo è successo a me quando ho copiato la mia configurazione di remmina (sotto ~/.remmina) da una macchina all'altra. Forse le versioni di remmina erano diverse; cambiare la sicurezza non ha aiutato ma ha cancellato e ricreato la connessione.


4
2018-02-12 22:25





Il problema è con l'impostazione viewmode = 1 nel file conf salvato. Se ridimensioni la finestra, dovrebbe aggiornarsi e iniziare a mostrare la sessione. La modifica di questo valore booleano su 0 costringerà la finestra ai valori predefiniti e verrà aggiornata al caricamento. Il problema è che se ridimensioni la finestra dopo l'avvio della sessione, remmina cambierà questa impostazione.

A work around would be to set the window_maximize=0 to true and then just click/press the maximize button/shortcut to bring it back to your settings. 
window_maximize=1 
window_height=960 
viewmode=1 
Window_width=1440

1
2018-02-27 14:21





Ha funzionato per me cambiando la sicurezza in NLA per qualche motivo sconosciuto.


1
2018-05-03 08:38



Benvenuto su Ask Ubuntu! Raccomando di modificare questa risposta per espanderla con dettagli specifici su come farlo. (Guarda anche Come scrivo una buona risposta? per un consiglio generale su quale tipo di risposte sono considerate più preziose su AskUbuntu.) - David Foerster
Mi sembra utile una risposta separata che puoi invitare e svalutare. Modificare le risposte di altre persone per inserire "bene, che dire di X", sembra il contrario di utile. Una cosa è correggere gli errori, andare avanti e modificare. Ma dire a una nuova persona di andare sul montaggio invece di dire che ciò che ha funzionato per loro sembra il contrario del bene. - Warren P


Probabilmente una risposta stupida, ma il problema per me è stato il tentativo di connettermi attraverso una rete Wi-Fi aperta (non criptata) e remmina non lo avrebbe permesso. Una volta connesso a una rete protetta, tutto ha funzionato come pianificato di nuovo.


0
2018-06-15 22:38



Non sarebbe carino se Remmina mostrasse effettivamente degli errori utili invece di fallire? - Warren P