Domanda No Wifi su Acer Aspire E5 573 su qualsiasi piattaforma Linux


Ho avviato il mio portatile Acer Aspire E5-573 con Windows 10 e Ubuntu 15.10 e dal primo giorno non sono più in grado di utilizzare il WiFi su qualsiasi piattaforma Linux. Ho fatto tutto ciò che avrei potuto fare ancora inutile. Nessun driver aggiuntivo disponibile per me su Ubuntu, ma sono perfettamente in grado di utilizzare WiFi su Windows 10. Il chip WiFi nel mio laptop è Qualcomm Atheros QCA9377 Wireless Network Adapter. Per favore, trovami una soluzione per questo.

    dmesg | grep ath10k
[   11.203844] ath10k_pci 0000:03:00.0: pci irq msi-x interrupts 8 irq_mode 0 reset_mode 0
[   11.599565] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/cal-pci-0000:03:00.0.bin failed with error -2
[   11.599579] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-5.bin failed with error -2
[   11.599582] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-5.bin': -2
[   11.599589] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-4.bin failed with error -2
[   11.599591] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-4.bin': -2
[   11.599596] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-3.bin failed with error -2
[   11.599598] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-3.bin': -2
[   11.599603] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware-2.bin failed with error -2
[   11.599605] ath10k_pci 0000:03:00.0: could not fetch firmware file 'ath10k/QCA9377/hw1.0/firmware-2.bin': -2
[   11.599610] ath10k_pci 0000:03:00.0: Direct firmware load for ath10k/QCA9377/hw1.0/firmware.bin failed with error -2
[   11.599612] ath10k_pci 0000:03:00.0: could not fetch firmware (-2)
[   11.599614] ath10k_pci 0000:03:00.0: could not fetch firmware files (-2)
[   11.599615] ath10k_pci 0000:03:00.0: could not probe fw (-2)

3
2017-12-30 14:02


origine


C'è un indizio nei registri dei messaggi? Si prega di aprire un terminale ed eseguire: dmesg | grep ath10k Modifica la tua domanda per aggiungere il risultato. - chili555
ogni volta che provo sudo cp -r ath10k-firmware / QCA9377 / lib / firmware / ath10k ottengo sudo: impossibile risolvere l'host nachiket-acer - Nachiket Deolankar
Perfavore guarda: askubuntu.com/questions/59458/... - chili555
per sudo apt-get install git questo è l'output: - Leggere gli elenchi dei pacchetti ... Fatto Costruire l'albero delle dipendenze Leggere le informazioni sullo stato ... Fatto Pacchetto git non è disponibile, ma viene chiamato da un altro pacchetto. Ciò potrebbe significare che il pacchetto è mancante, è stato obsoleto o è disponibile solo da un'altra fonte E: Il pacchetto 'git' non ha candidati all'installazione - Nachiket Deolankar
Mi chiedo perché un pacchetto comunemente disponibile, idiota non è installabile, insieme a tutte le sue dipendenze, sul tuo sistema. packages.ubuntu.com/wily/git Questo è un buon argomento per una nuova domanda separata. In tal caso, correggerò la mia risposta per fornire un metodo alternativo per scaricare e installare il firmware mancante. - chili555


risposte:


Sembra che sia necessario ma manca il firmware richiesto. Con una connessione Internet funzionante via ethernet, collegato o qualsiasi altro mezzo possibile, apri un terminale e fai:

wget https://github.com/kvalo/ath10k-firmware/archive/master.zip
unzip master.zip
sudo cp -r ath10k-firmware-master/QCA9377 /lib/firmware/ath10k/
sudo mv /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin_WLAN.TF.1.0-00267-1 /lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin

Riavvia e il tuo wireless dovrebbe funzionare.


6
2017-12-30 14:55



Ho appena provato questo e ha funzionato. Grazie mille! - dzhi
questo non ha funzionato per me - Suraj
@Suraj Per favore inizia la tua nuova domanda e saremo felici di aiutarti. - chili555