Domanda GLEW di apt-get non ha file inclusi


Informazioni sull'ambiente: ubuntu 14.04 LTS

Io solo sudo apt-get install glew-utils. Ma quando io find / -name "*glew*" Ho qualcosa del genere:

/usr/share/doc/libglewmx1.10
/usr/share/doc/glew-utils
/usr/share/doc/libglew1.10
/usr/bin/glewinfo

Ma l'atteso /include e /lib è mancato!

L'apt-get ha qualche errore con qualcosa che non conosco, che si chiama cups qui. E le cuciture in dpkg devono essere bloccate da queste tazze. La mia ipotesi è giusta? E come ripararlo?

ndn-07@ndn07-desktop:~$ sudo apt-get install glew-utils 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
glew-utils is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1293 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up cups-daemon (2.0.2-1ubuntu3.2) ...
AppArmor parser error for /etc/apparmor.d/usr.sbin.cupsd in /etc/apparmor.d/usr.sbin.cupsd at line 145: syntax error, unexpected TOK_CONDLISTID, expecting TOK_MODE
update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match cups Default-Stop values (1)
/usr/sbin/invoke-rc.d: 1: /usr/sbin/invoke-rc.d: /sbin/runlevel: not found
start: Job failed to start
invoke-rc.d: initscript cups, action "start" failed.
dpkg: error processing package cups-daemon (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of cups-core-drivers:
 cups-core-drivers depends on cups-daemon (>= 2.0.2-1ubuntu3.2); however:
  Package cups-daemon is not configured yet.

dpkg: error processing package cups-core-drivers (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          dpkg: dependency problems prevent configuration of cups:
 cups depends on cups-core-drivers (>= 2.0.2-1ubuntu3.2); however:
  Package cups-core-drivers is not configured yet.
 cups depends on cups-daemon (>= 2.0.2-1ubuntu3.2); however:
  Package cups-daemon is not configured yet.

dpkg: error processing package cups (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          E: Sub-process /usr/bin/dpkg returned an error code (1)

====================

Qualche errore quando aggiornamento e aggiornamento potrebbero avere una relazione con questo problema:

==================== aggiornamento

Hit http://mirrors.163.com vivid-backports/main Translation-en
Hit http://mirrors.163.com vivid-backports/multiverse Translation-en
Hit http://mirrors.163.com vivid-backports/restricted Translation-en
Hit http://mirrors.163.com vivid-backports/universe Translation-en
Fetched 7,962 kB in 2min 46s (47.8 kB/s)
W: Failed to fetch bzip2:/var/lib/apt/lists/partial/mirrors.163.com_ubuntu_dists_vivid-security_main_i18n_Translation-en  Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/mirrors.163.com_ubuntu_dists_vivid-updates_universe_binary-amd64_Packages  Hash Sum mismatch

W: Failed to fetch bzip2:/var/lib/apt/lists/partial/mirrors.163.com_ubuntu_dists_vivid-updates_main_binary-i386_Packages  Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

================= aggiornamento

 xul-ext-ubufox xul-ext-unity xul-ext-webaccounts
  xul-ext-websites-integration yelp yelp-xsl zeitgeist zeitgeist-core
  zeitgeist-datahub zenity zenity-common zlib1g
963 upgraded, 0 newly installed, 0 to remove and 330 not upgraded.
3 not fully installed or removed.
Need to get 331 kB/363 MB of archives.
After this operation, 94.6 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://mirrors.163.com/ubuntu/ vivid/main libasound2 amd64 1.0.28-1 [331 kB]
Fetched 374 kB in 0s (1,715 kB/s)  
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: You may want to run apt-get update to correct these problems
E: Failed to fetch http://mirrors.163.com/ubuntu/pool/main/a/alsa-lib/libasound2_1.0.28-1_amd64.deb  Size mismatch

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

=============== apt-get install -f

 xserver-common xserver-xorg-input-all xserver-xorg-video-all xterm
  xul-ext-ubufox xul-ext-unity xul-ext-webaccounts
  xul-ext-websites-integration yelp yelp-xsl zeitgeist zeitgeist-core
  zeitgeist-datahub zenity zenity-common zlib1g
963 upgraded, 0 newly installed, 0 to remove and 330 not upgraded.
3 not fully installed or removed.
Need to get 331 kB/363 MB of archives.
After this operation, 94.6 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://mirrors.163.com/ubuntu/ vivid/main libasound2 amd64 1.0.28-1 [331 kB]
Fetched 374 kB in 0s (1,715 kB/s)  
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: You may want to run apt-get update to correct these problems
E: Failed to fetch http://mirrors.163.com/ubuntu/pool/main/a/alsa-lib/libasound2_1.0.28-1_amd64.deb  Size mismatch

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
ndn-07@ndn07-desktop:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1293 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up cups-daemon (2.0.2-1ubuntu3.2) ...
AppArmor parser error for /etc/apparmor.d/usr.sbin.cupsd in /etc/apparmor.d/usr.sbin.cupsd at line 145: syntax error, unexpected TOK_CONDLISTID, expecting TOK_MODE
update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match cups Default-Stop values (1)
/usr/sbin/invoke-rc.d: 1: /usr/sbin/invoke-rc.d: /sbin/runlevel: not found
start: Job failed to start
invoke-rc.d: initscript cups, action "start" failed.
dpkg: error processing package cups-daemon (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of cups-core-drivers:
 cups-core-drivers depends on cups-daemon (>= 2.0.2-1ubuntu3.2); however:
  Package cups-daemon is not configured yet.

dpkg: error processing package cups-core-drivers (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          dpkg: dependency problems prevent configuration of cups:
 cups depends on cups-core-drivers (>= 2.0.2-1ubuntu3.2); however:
  Package cups-core-drivers is not configured yet.
 cups depends on cups-daemon (>= 2.0.2-1ubuntu3.2); however:
  Package cups-daemon is not configured yet.

dpkg: error processing package cups (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          Errors were encountered while processing:
 cups-daemon
 cups-core-drivers
 cups
E: Sub-process /usr/bin/dpkg returned an error code (1)

============== dopo l'elenco di apt pulito

  xul-ext-ubufox xul-ext-unity xul-ext-webaccounts
  xul-ext-websites-integration yelp yelp-xsl zeitgeist zeitgeist-core
  zeitgeist-datahub zenity zenity-common zlib1g
963 upgraded, 0 newly installed, 0 to remove and 330 not upgraded.
3 not fully installed or removed.
Need to get 331 kB/363 MB of archives.
After this operation, 94.6 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://mirrors.163.com/ubuntu/ vivid/main libasound2 amd64 1.0.28-1 [331 kB]
Fetched 374 kB in 0s (973 kB/s)    
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: Unknown Multi-Arch type 'no' for package 'compiz-core'
W: Unknown Multi-Arch type 'no' for package 'compiz-gnome'
W: You may want to run apt-get update to correct these problems
E: Failed to fetch http://mirrors.163.com/ubuntu/pool/main/a/alsa-lib/libasound2_1.0.28-1_amd64.deb  Size mismatch

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
ndn-07@ndn07-desktop:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 1293 not upgraded.
3 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up cups-daemon (2.0.2-1ubuntu3.2) ...
AppArmor parser error for /etc/apparmor.d/usr.sbin.cupsd in /etc/apparmor.d/usr.sbin.cupsd at line 145: syntax error, unexpected TOK_CONDLISTID, expecting TOK_MODE
update-rc.d: warning: default stop runlevel arguments (0 1 6) do not match cups Default-Stop values (1)
/usr/sbin/invoke-rc.d: 1: /usr/sbin/invoke-rc.d: /sbin/runlevel: not found
start: Job failed to start
invoke-rc.d: initscript cups, action "start" failed.
dpkg: error processing package cups-daemon (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of cups-core-drivers:
 cups-core-drivers depends on cups-daemon (>= 2.0.2-1ubuntu3.2); however:
  Package cups-daemon is not configured yet.

dpkg: error processing package cups-core-drivers (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of cups:
 cups depends on cups-core-drivers (>= 2.0.2-1ubuntu3.2); however:
  Package cups-core-drivers is not configured yet.
 cups depends on cups-daemon (>= 2.0.2-1ubuntu3.2); however:
  Package cups-daemon is not configured yet.

dpkg: error processing package cups (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          No apport report written because the error message indicates its a followup error from a previous failure.
                                                     E: Sub-process /usr/bin/dpkg returned an error code (1)
ndn-07@ndn07-desktop:~$ sudo apt-get install glew-utils 

3
2018-04-07 13:35


origine


Invia il messaggio di errore completo non solo "L'apt-get ha qualche errore con qualcosa che non conosco" - Parto
@Parto scusa, l'ho modificato di nuovo. - Frank Wang
Qual è la tua versione di Ubuntu? - Parto
@Parto 14.04LTS, hai bisogno di altre informazioni? :) - Frank Wang
Chiederò mentre procedo. Per ora prova sudo apt-get update poi sudo apt-get upgrade poi sudo apt-get install -f in questo ordine. Modifica la tua domanda quindi includi l'output in cui compare un errore. - Parto


risposte:


Non so perché ti aspetti che installi qualcosa in quelle directory. Ma quello che vedi è corretto, non c'è niente di sbagliato nel pacchetto.

Il pacchetto fornisce i seguenti file:

/usr/bin/glewinfo  
/usr/bin/visualinfo  
/usr/share/doc/glew-utils/README.txt  
/usr/share/doc/glew-utils/TODO.txt  
/usr/share/doc/glew-utils/changelog.Debian.gz  
/usr/share/doc/glew-utils/copyright

Fonte: http://packages.ubuntu.com/trusty/amd64/glew-utils/filelist


1
2018-04-11 05:54



@ FrankWang Hai risolto il tuo problema "dpkg error"? - Parto
@Parto No, ma le cuciture del problema 'dpkg error' non hanno alcun effetto sul mio utilizzo. Come ha detto la risposta, il pacchetto ubuntu fornisce non ha incluso il file lib e include affatto. È piuttosto drammatico, e mi sentivo in colpa per la tua offerta di munizioni. Dopo tutto, l'ho installato tramite il codice sorgente e funziona. - Frank Wang
È bello Ecco perché siamo qui, per aiutarci l'un l'altro. Sono felice per l'opportunità. - Parto