Domanda Unity non viene caricato, nessun Launcher, nessun Dash appare


Quando accedo, non succede niente.

Mi viene presentato il mio sfondo del desktop.

Blank desktops suck

No Dash, no Launcher, niente.


535
2017-12-14 17:24


origine


IMHO questo è un bug, ma ce l'ho da oggi. Potrebbe solo trovare questo bug bugs.launchpad.net/ubuntu/+source/unity/+bug/1212987 Ho seguito le raccomandazioni qui: askubuntu.com/questions/17381/... Unity è stato resettato ma non funziona OK, gli spazi di lavoro non funzionano, anche se abilito o disabilito o cambio quantità. Nessuna differenza. Il plug-in put interrompe anche l'unità, - Janghou
I miei problemi sono iniziati dopo il passaggio dai driver nouveau ai driver NVIDIA (impostazioni di sistema / scheda hardware). - DanielaWaranie
Dopo molti giorni trascorsi e molti thread SO letti, ho scoperto che questo sembra essere un bug aperto di Ubuntu (stato 'incompleto' a partire da luglio 2015). Maggiori informazioni su di esso qui: bugs.launchpad.net/ubuntu/+bug/1285444  La soluzione rapida sembra essere: $ mv ~/.config/dconf/user ~/.config/dconf/user.old - xyz
@ julianromera è stata l'unica soluzione su questo thread che mi ha aiutato - Dziamid
la risposta @julianromera è stata l'unica che ha funzionato per me. - Paweł Adamski


risposte:


Questa risposta applica le versioni di Ubuntu con Compiz.

Questa risposta presuppone che Unity è stato eseguito attraverso Compiz. Se non lo hai compiz installato questa risposta non si applica a voi.

Hai solo bisogno di riattivare il plugin Unity. Il problema è che questo è un dolore in fondo perché ora non hai un metodo grafico per farlo. Così:

  1. Prova ad aprire un terminale con Ctrl+alt+T.
    Questo potrebbe non funzionare ma puoi provare a fare clic destro sul desktop e selezionare "Apri terminale qui". In caso contrario, potrebbe essere necessario passare a un terminale "rigido" premendo Ctrl+alt+F1 e accedi.

  2. Installare compizconfig-settings-manager correndo

    sudo apt-get install compizconfig-settings-manager
    
  3. Quindi eseguilo con questo:

    DISPLAY=:0 ccsm &
    

    La prima parte dice al terminale su quale display vuoi che si carichi (altrimenti non ne ha la minima idea).

  4. Se si passa a un TTY al punto 1, tornare al server grafico premendo Ctrl+alt+F7 (o Ctrl+alt+F8 a volte).
    Ci dovrebbe essere un gestore delle impostazioni di CompizConfig che ti aspetta.

  5. Trova il plug-in Unity. Abilitalo. Ti verrà chiesto "Ubuntu Unity Plugin richiede il plugin OpenGL. Abilita Ubuntu Unity Plugin / Enable OpenGL"

  6. Tutto dovrebbe germogliare nella vita, ma in caso contrario, potrebbe essere necessario riavviare. Puoi farlo tornando al terminale e correndo sudo reboot.


465
2017-11-07 23:23



Ha funzionato perfettamente bene per me. Come nota a margine, non avevo bisogno di inserire il terminale TTY, ero in grado di usare la scorciatoia del terminale (ctrl + alt + t). - Tass
Se arrivi al punto 5 e non vedi l'unità nell'elenco, prova questo: sudo apt-get -f install && sudo apt-get --reinstall install unity - Collinux
Ho avuto questo problema da solo, ma sono sfortunato con la soluzione lontana, non funziona per me, ho ancora lo stesso schermo vuoto su Ubuntu 14.04 LTS a 64 bit. Andrà di nuovo sui gradini per controllare se qualche cosa è stata persa. Lenovo X201S Thinkpad i7 2.0 Ghz 8 GB di RAM. Mai avuto questo problema con 12.04 LTS - therobyouknow
Il fatto che questo sia un problema così comune e duraturo è per me piuttosto inquietante. Qualcuno sa perché questo continua a succedere, e cosa lo sta causando? - fouric
ccsm si blocca su Caricamento icone, ma se ctrl-alt-F7 torna al display principale, le opzioni compiz SONO lì. Ho abilitato il desktop Unity, ritorna a tty1 (ccsm è stato eseguito con successo) ... ma non Unity. Riavvio: nessuna unità. Se ricarico ccsm, Unity è ancora selezionato e "on" ma non appare Unity. - JeanSibelius


Una soluzione buona per me (ha risolto lo stesso problema):

in un terminale:

export DISPLAY=:0   
sudo dconf reset -f /org/compiz/

e poi

setsid unity

166
2018-05-04 00:50



Fantastico. Funziona con Ubuntu Linux 13.04 Desktop in Parallels su Mac OS X. - Elliot
Grazie! Funziona anche con Ubuntu 14.04. Mi chiedo perché questo sia accaduto in modo inaspettato però :-( - Sadi
avevo bisogno export DISPLAY=:0 primo. - Uri
sudo dconf reset -f / org / compiz / riga di comando spawning errore 'dbus-launch --autholaunch = c0c0f8bf86119c64ccb710000000006 --base-syncax --close-stderr': processo figlio terminato con codice 1 - JeanSibelius
Un problema con questo è quello in esecuzione dconf come sudo fatto il mio ~/.config/dconf/user il file ha root proprietà (aveva la proprietà dell'utente prima). Mi chiedo se dovrebbe essere fatto senza sudo. Questo è stato molto meglio che rimuovere il file e partire da zero! - Tim Tisdall


Nel 13.04 e 14.04:

unity --replace è deprecato. Invece, utilizzare il seguente:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Riavvia se non funziona immediatamente.


72
2018-04-27 02:39



Questo ha funzionato per me dopo aver installato i driver appropriati per la mia scheda grafica Nvidia. Vedi la mia risposta askubuntu.com/questions/288235/... - Thomas Arildsen
dconf reset comando restituisce l'errore 1 del codice di uscita e non funzionerà 13.10. - Peterdk
abilitando i plugin Unity con ccsm risolto alcuni dei problemi, il resto è stato risolto con rm -r .Xauthority .ICEauthority .compiz-1/ .gconf/ .config/compiz-1/ .config/dconf/ - precise
Impossibile avviare il D-bus senza X11 $ DISPLAY. Niente ha funzionato finora - jimifiki
Funziona anche per Ubuntu 16.04, ha appena risolto il mio problema - Priyadarshi Paul


Per 12.10 e seguenti:

stampa Ctrl+alt+T per un terminale e correre ccsm, quindi riattiva il tuo plug-in 'Unity'.

Potrebbe anche essere necessario eseguire a unity --replace.


60
2017-10-02 02:33



unity --reset è deprecato ora e non funziona. C'è una sostituzione? - Shahbaz
@Shahbaz - unity --replace. - horIzoN
@ nerof61 anche deprecato dal 13.04. Vedi la mia risposta qui sotto: askubuntu.com/a/286349/2638 - Brandon Bertelsen
nessuno dei due --reset né --replace ha funzionato per me con la mia Ubuntu 12.04 .. eseguendo i comandi immediatamente visualizzati unity-panel-service: no process found Backend : ini Integration : true Profile : default Adding plugins Initializing core options...done ... Ho aspettato e aspettato, e poi non ho potuto, interrotto con ctrl + c .. e ora cercando di provare quali altre risposte suggerite .. - precise


È una buona idea controllare che il driver grafico sia configurato per utilizzare l'accelerazione hardware e che sia configurato per utilizzare OpenGL. Prova a cercare Forum Ask Ubuntu e Ubuntu per informazioni specifiche per le tue GPU e il gusto di Ubuntu. Per gli utenti di grafica ibrida, consultare l'ultima sezione "Grafica ibrida" di seguito.

Potresti voler eseguire il compizconfig-settings-manager  Install compizconfig-settings-manager pacchetto e assicurati che il plugin Unity sia selezionato (vedi Quali sono alcuni dei problemi con CCSM e perché dovrei evitarlo?).

Per 12.04 E più recenti

  1. Cambia in tty1 premendo Ctrl+alt+F1 e accedi.

  2. Installare compizconfig-settings-manager correndo

    sudo apt-get install compizconfig-settings-manager
    
  3. Quindi eseguirlo facendo questo:

    export DISPLAY=:0
    ccsm
    

    La prima parte dice al terminale su quale display vuoi che si carichi (altrimenti non ne ha la minima idea).

  4. stampa Ctrl+alt+F7 (o Ctrl+alt+F8 a volte) per tornare al display grafico in cui dovrebbe esserci una schermata di Gestione impostazioni CompizConfig seduta lì.

  5. Trova il plug-in Unity. Abilitalo. CCSM

  6. Tutto dovrebbe germogliare nella vita, ma in caso contrario, potrebbe essere necessario riavviare. Puoi farlo tornando a tty1e in esecuzione sudo reboot.

Se l'unità continua a non caricare, prova:

dconf reset -f /org/compiz/
unity --reset-icons &disown

Riavvia se non funziona immediatamente.

Per 11.10 E più vecchio

Se speri in un TTY (Ctrl+alt+F1 attraverso F6) e corri:

DISPLAY=:0 unity --replace

Reimposta Unity su TTY 7 (Ctrl+alt ++F7).

Puoi anche provare solo:

DISPLAY=:0 unity

Ma questo non funzionerà se un windows manager è già in esecuzione sul display 0 (ti darà un errore, basta usare unity --replace in quel caso).

Se l'unità assolutamente rifiuta di riavviare prova questo:

Installare gnome-panel:

sudo apt-get install gnome-panel

Di eseguirlo sul display 0:

DISPLAY=:0 gnome-panel

Dovresti quindi avere i pannelli di stile Gnome 2 sul desktop, che puoi usare per uscire.

Grafica ibrida

È possibile trovare alcune informazioni molto utili e ulteriori letture per gli utenti di grafica ibrida Qui.

Una volta che le GPU sono configurate in modo appropriato per l'accelerazione 3D e OpenGL puoi:

  1. Installa i driver Nvidia da https://edge.launchpad.net/~xorg-edgers/+archive/ppa:

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    o:

    Preferirei davvero il PPA stabile, ma non sembra avere ancora pacchetti per la 13.04. Aggiornamento: questi sembrano essere disponibili dal 25 settembre. Installerei questo PPA stabile - puoi provare ma non l'ho testato.

    I driver Nvidia forniti da Ubuntu erano già installati e ho semplicemente installato da questo PPA aggiungendolo e facendo un aggiornamento del pacchetto usando update-manager.

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    
  2. Installa Bumblebee da https://launchpad.net/~bumblebee/+archive/stable

    AGGIORNAMENTO: dal 6 ottobre ppa:xorg-edgers/ppa sembra contenere anche calabrone. Quindi, se si installa da questo PPA, si potrebbe voler provare a saltare l'aggiunta del PPA Bumblebee e installarlo da qui invece.

    Se hai scelto il PPA stabile nel passaggio 1, installa il PPA stabile di Bumblebee come segue:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. AGGIORNAMENTO: dopo aver aggiunto i PPA, aggiorna gli elenchi dei pacchetti:

    sudo apt-get update
    

    Se hai già installato i driver nvidia dagli archivi standard di Ubuntu, esegui semplicemente l'upgrade per ottenere la nuova versione dal repository scelto nel passaggio 1:

    sudo apt-get upgrade
    sudo apt-get install bumblebee
    
  4. Eseguire i seguenti comandi per 'riparare' Unity (da brandon-BertelsenLa risposta a Unity non viene caricato, nessun Launcher, nessun Dash appare):

    dconf reset -f /org/compiz/
    unity --reset-icons & disown
    

51
2017-12-27 12:45



In 14.10: unity --reset-icons & disown mi ferma: job sconosciuto: unity-panel-service // start: job sconosciuto: unity-panel-service // compiz (core) - Info: plugin di caricamento: core // compiz (core) - Info: plugin di partenza: core ... e nessuna ulteriore azione. Alt-F7 mi riporta in grafico dove ho un menu laterale ma nessun menu "start" (niente nel menu in alto - nessuna icona di connettività, icona di alimentazione, ecc.) - tty1 mi dà schermate e schermate di informazioni. .. riavvia e RITORNO IN BUSINESS! GRAZIE PER IL TUO MAGO VOODOO - JeanSibelius
La tua sezione "For 12.04 e più recente" non funziona su Ubuntu 16.04. - Luís de Sousa
apt-add-repository? - mancante - Kalpesh Soni


Il modo più semplice per farlo è quello di premere Ctrl+alt+T per ottenere un terminale e quindi emettere:

rm -rf ~/.compiz-1 ~/.config/compiz-1

e la tua sessione di unità tornerà davanti ai tuoi occhi ..

Questa tecnica è migliore del rilancio di ccsm, perché è possibile entrare nella condizione di errore dell'OP senza deselezionare accidentalmente l'unità in ccsm; puoi ottenerlo semplicemente premendo accidentalmente il pulsante "Preferenze" in ccsm.


32
2017-11-10 05:55



Immagino tu intenda .config / compiz-1 - matteo
Non posso usare ctrl-alt-T - jimifiki
@jimifiki: premi 'crtl' + 'alt' + 'f1' e poi fai quello che achiang suggeriva. anche se personalmente li sposterei di mezzo in caso trovassi più problemi. - isaaclw
@isaaclw Ho fatto ciò che suggerisce. Niente è cambiato. Sorprendentemente la sessione ospite funziona normalmente. - jimifiki
Per la mia Ubuntu 16.04, erano presenti i file rilevanti da rimuovere .cacheno .config. Così rm -rf ~/.cache/compizconfig-1 ha funzionato per me - tparker


Ho avuto anche questo problema. L'ho risolto eliminando il contenuto del file ~ / .config / compiz-1 / compizconfig e relog.

rm -rf ~/.config/compiz-1/compizconfig/*

25
2017-10-30 06:23



non ha funzionato per me, praticamente come tutto il resto in questa pagina - matteo
Sì! Grazie, ha funzionato! Ho Ubuntu 16.04 installato in VirtualBox e dopo uno degli aggiornamenti ho avuto questo problema. Questa è l'unica soluzione che ha funzionato per me! Oh, e non dimenticare di riavviare dopo aver applicato questa correzione. - informatik01
Non funziona su Ubuntu 16.04. - Luís de Sousa
Non ha funzionato per me il 16.04 - 43Tesseracts
Per la mia Ubuntu 16.04, erano presenti i file rilevanti da rimuovere .cacheno .config. Così rm -rf ~/.cache/compizconfig-1 ha funzionato per me - tparker