Domanda Impossibile installare Cura 3.1 su Ubuntu 16.04


Sto cercando di scaricare il software Cura slicer sul mio computer e continuo a rimanere bloccato nelle mie tracce. Ho provato sudo apt update     e ottengo questo messaggio:

Aborted (core dumped)
Reading package lists... Done
N: Ignoring file 'sp' in directory '/etc/apt/sources.list.d/' as it has no filename extension
N: Ignoring file 'google-chrome.lis' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/cache/app-info -a -e /usr/bin/appstreamcli; then appstreamcli refresh > /dev/null; fi'
E: Sub-process returned an error code

Ho provato a installare con

sudo apt-get install cura    

ma poi ottengo:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cura : Depends: python3-uranium but it is not going to be installed
        Depends: qml-module-qtqml-models2 but it is not installable
        Depends: qml-module-qtquick-controls but it is not installable
        Depends: qml-module-qtquick-dialogs but it is not installable
        Recommends: cura-resources-firmware but it is not going to be installed
        Recommends: cura-plugins-all but it is not going to be installed
        Recommends: python3-numpy-stl but it is not installable
N: Ignoring file 'sp' in directory '/etc/apt/sources.list.d/' as it has no filename extension
N: Ignoring file 'google-chrome.lis' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Unable to correct problems, you have held broken packages.

Ho provato

sudo ppa-purge ppa:thopiekar/cura    

ma mi dice: sudo: ppa-purge: command not found

Sono nuovo di Linux e ho solo poca esperienza. Per favore, spiega cosa stai cercando di dirmi in parole povere. Grazie in anticipo.


2
2018-01-27 02:41


origine


Per formattare i comandi che hai digitato nel mezzo di un altro testo, racchiudili con `S. Per formattare l'output del terminale, selezionarlo e premere il tasto {} pulsante nell'editor. - Chai T. Rex
Per ppa-purge per funzionare, deve essere installato. sudo apt install ppa-purge - Terrance
Hai incasinato i tuoi repository o dipendenze. Did apt-get install -f o dpkg --configure -a Aiuto? Si prega di aggiornare la domanda con l'output del seguente comando grep -v ^# -r /etc/apt/sources.list /etc/apt/sources.list.d/*.list | grep deb (tutti i repository saranno abilitati). - N0rbert


risposte:


Cura 2.7 è installabile da ppa: thopiekar / cura:

sudo add-apt-repository ppa:thopiekar/cura
sudo apt-get update 
sudo apt-get install cura

Se hai bisogno di una versione più recente di Cura, puoi usarla ppa: thopiekar / cura-master

sudo add-apt-repository ppa:thopiekar/cura-master
sudo apt-get update
sudo apt-get install cura

2
2018-01-27 10:11



Ho fatto un'installazione pulita e ho risolto TUTTI i miei problemi, tra cui Facebook non riproduceva video su Firefox e Spotify non era in grado di riprodurre musica. - lostinlinux
questo repository ha solo cura 2.7 e l'ultima ora è 3.4. - Kostanos
@ Kostanos Trova il nuovo PPA da solo e condividi il link qui. Per favore. - N0rbert
nah, basta scaricarlo dal loro sito: ultimaker.com/en/products/ultimaker-cura-software ed eseguilo - Kostanos


Il repository menzionato nella risposta accettata non è aggiornato, ha solo 2.7 versione di cura. Attualmente il modo migliore per installarlo è scaricarlo da sito di cura direttamente.

wget https://download.ultimaker.com/current/Cura-3.4.1.AppImage
sudo mv Cura-3.4.1.AppImage /usr/bin/cura
sudo chmod +x /usr/bin/cura

Ora puoi solo correre cura


1
2017-08-09 20:58