Domanda Come rimuovere o riparare in sicurezza il pacchetto plymouth?


Ho un pacco rotto ... Fin qui niente di orribile. Il problema è che è Plymouth, e sembra che se lo rimuoverò, rimuoverò metà dei pacchetti del mio sistema ... Quindi ecco la mia domanda: se effettivamente rimuovo, o addirittura spurgo Plymouth; avrò almeno un terminale a sinistra dopo di esso per reinstallarlo? O sono decisamente condannato?

Giusto per illustrare ciò che dico; ecco il risultato di un

apt-get --reinstall installa plymouth:

julien@julien-desktop:~$ sudo apt-get --reinstall install plymouth
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reinstallation of plymouth is not possible, it cannot be downloaded.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 plymouth : Depends: libdrm-nouveau1 (>= 2.4.11-1ubuntu1~) but it is not installable
            Recommends: plymouth-themes-all but it is not installable
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

o un

apt-get -f install

(beh, in pratica è lo stesso)

julien@julien-desktop:~$ sudo apt-get -f install
[sudo] password for julien: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 plymouth : Depends: libdrm-nouveau1 (>= 2.4.11-1ubuntu1~) but it is not installable
            Recommends: plymouth-themes-all but it is not installable
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
julien@julien-desktop:~$ 

Qualsiasi idea sarebbe molto gradita ...


2
2018-04-09 19:42


origine


PS: se qualcuno vuole sapere come sia successo ... Beh, ho più o meno il problema dall'installazione (ieri): il sistema non voleva eseguire l'aggiornamento completo (vedi thread collegamento ). Dopo un giorno ho deciso di occuparmi di pb: python era uno dei pacchetti riluttanti, ha detto che aveva conflitti con un altro pacchetto durante l'aggiornamento, quindi ho provato ad aggiornare usando --force-overwrite ... ed eccomi qui. - Julien Gorenflot
Quindi .. Hai cercato le dipendenze per installarle manualmente? - Uri Herrera


risposte:


È possibile rimuoverlo. Il bug report # 556372 descrive il problema Dave Lentz ha un PPA che funziona attorno a questi problemi. Quindi devi aggiungere il PPA:

sudo apt-add-repository ppa:dtl131/mediahacks
sudo aptitude update

Ora devi aggiornare mountall alla versione (ad aprile 2012): 2.25ubuntu2 ~ mediahacks1. Al termine, è possibile disinstallare Plymouth senza disinstallare metà del sistema.


2
2018-04-09 22:30



Sembra che abbia funzionato !!! Mi hai salvato la vita (beh, diciamo che mi ha salvato in modo epocale dalla depressione almeno: p)! Dopo aver trascorso il mio weekend al lavoro per l'installazione, non volevo dover ripetere lo stesso sul mio orario di lavoro! - Julien Gorenflot
Bello sentire :-) Quindi potresti voler accettare la mia risposta, in modo che altri utenti vedano facilmente che potrebbe anche aiutarli. - qbi
Yop! Grazie ancora! - Julien Gorenflot