Domanda GNOME Ubuntu 15.04 che interseca i layout di tastiera


Ho Ubuntu 15.04 con installazione di Gnome 3 in cui l'inglese (USA) è il primo layout di tastiera e il russo è il secondo. Dopo l'avvio del sistema, l'inglese viene usato di default e dopo che ho cambiato il russo per la prima volta il layout in uso è ancora inglese, sebbene lo switcher di layout mostri "ru". E quando cambio di nuovo mostra "en", ma in realtà è russo.

Non è stato un grosso problema prima di aver sostituito En-US con English International, perché si comporta ancora come En-US: posso usare caratteri internazionali con tasto compose solo mentre l'inglese rimane in inglese prima di cambiare il layout per la prima volta. Qualcuno può aiutarmi a risolvere questo?

Il mio sistema lang è impostato su En-US e i formati sono Stati Uniti se è importante.


2
2018-06-10 18:18


origine


Puoi copiare per favore il tuo "P.P.S." a una risposta e accettare quella risposta per contrassegnare il problema risolto. - Gunnar Hjalmarsson


risposte:


Risolto nella domanda da OP

Ho appena notato che uso sempre alt+Cambio per passare da un layout all'altro. Ma ora ho provato a usarlo alt+Spazio e tutto funziona come previsto!


0



Questo risolve il mio problema, ma non risolve il problema di alt + shift. Preferirei usarlo invece di vincere + spazio - Anzor A. Khoutov
Sì, ma dovrebbe funzionare. Non vedo perché dovrei essere costretto a usare una scorciatoia funzionante quando sono abituato a un setup diverso. Cosa succede se si scontra con il mio flusso di lavoro? Fornitori proprietari che applicano le loro regole e limitano gli utenti = storia diversa, ciò che accade in FOSS = non è accettabile. Quirk come questi accadono sempre ed è davvero fastidioso. Prendi qualcuno che lavora come traduttore e ha bisogno di passare rapidamente da una lingua all'altra. - Inoki
Umm ok, invia una segnalazione di bug allora? Chiedi a Ubuntu non fare Ubuntu. - Tim
Mi piacerebbe @ Tim, ma non so quale pacchetto dovrei presentare una segnalazione di bug. Ho provato qualsiasi cosa dal menu dei modificatori, nemmeno i citati lavori ALT + Space. Di solito uso il tasto Shift giusto perché è l'unico che non uso per niente ed è il modo più veloce per me. Non voglio usare altre opzioni perché utilizzo principalmente applicazioni grafiche con scorciatoie personalizzate che potrebbero intervenire. - Inoki
@ Tim ho trovato alla fine il pacchetto (spero) e postato il bug qui bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/... - Inoki